hdu 6406

hdu 6406

Taotao Picks Apples

Time Limit: 2000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 3140 Accepted Submission(s): 976


 

Problem Description

There is an apple tree in front of Taotao's house. When autumn comes, n apples on the tree ripen, and Taotao will go to pick these apples.

When Taotao picks apples, Taotao scans these apples from the first one to the last one. If the current apple is the first apple, or it is strictly higher than the previously picked one, then Taotao will pick this apple; otherwise, he will not pick.

Given the heights of these apples h1,h2,⋯,hn , you are required to answer some independent queries. Each query is two integers p,q , which asks the number of apples Taotao would pick, if the height of the p -th apple were q (instead of hp ). Can you answer all these queries?

 

Input

The first line of input is a single line of integer T (1≤T≤10) , the number of test cases.

Each test case begins with a line of two integers n,m (1≤n,m≤105) , denoting the number of apples and the number of queries. It is then followed by a single line of n integers h1,h2,⋯,hn (1≤hi≤109) , denoting the heights of the apples. The next m lines give the queries. Each of these m lines contains two integers p (1≤p≤n) and q (1≤q≤109) , as described in the problem statement.

 

Output

For each query, display the answer in a single line.

 

Sample Input

1 5 3 1 2 3 4 4 1 5 5 5 2 3

 

Sample Output

1 5 3

Hint

For the first query, the heights of the apples were 5, 2, 3, 4, 4, so Taotao would only pick the first apple. For the second query, the heights of the apples were 1, 2, 3, 4, 5, so Taotao would pick all these five apples. For the third query, the heights of the apples were 1, 3, 3, 4, 4, so Taotao would pick the first, the second and the fourth apples.

 

 

#include<bits/stdc++.h>
using namespace std;
int n,m,t,f[1000005],g[1000005],a[1000005];
int query(int l,int r,int res,int v)
{
	if(l==r) return f[res]>v;//如果到了根节点 判断是否大于v 大于则返回1不然就返回0 
	if(f[res]<=v) return 0;//这个区间最大的一个数都小于v那么这个区间就没有贡献 
	int mid=(l+r)/2;
	if(f[res*2]<=v) return query(mid+1,r,res*2+1,v);//如果左边的结果小于v 那么只有右边才可以 左边的都不行 
	else return g[res]-g[res*2]+query(l,mid,res*2,v);//不然的话就是加上右边的值 再递归找到左儿子的值 
}
void build(int l,int r,int res)
{
	if(l==r)
	{
		f[res]=a[l];
		g[res]=1;
		return;
	}
	int mid=(r+l)/2;
	build(l,mid,res*2);
	build(mid+1,r,res*2+1);
	f[res]=max(f[res*2],f[res*2+1]);
	g[res]=g[res*2]+query(mid+1,r,res*2+1,f[res*2]);//能选的苹果数等于左边的苹果数加上右边符合条件的苹果数 
}
void update(int l,int r,int res,int x,int y)
{
	if(l==r)
	{
		f[res]=y;
		g[res]=1;
		return;
	}
	int mid=(l+r)/2;
	if(x<=mid) update(l,mid,res*2,x,y);
	else update(mid+1,r,res*2+1,x,y);
	f[res]=max(f[res*2],f[res*2+1]);
	g[res]=g[res*2]+query(mid+1,r,res*2+1,f[res*2]);
}
int main()
{
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(int i=1;i<=n;i++)
		scanf("%d",&a[i]);
		build(1,n,1);//建树 
		while(m--)
		{
			int x,y;
			scanf("%d%d",&x,&y);
			int temp=a[x];
			update(1,n,1,x,y);
			printf("%d\n",g[1]);
			update(1,n,1,x,temp);//把原先的操作改回来 
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值