求逆元 费马小

hdu 657

Rng

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 244    Accepted Submission(s): 154


 

Problem Description

Avin is studying how to synthesize data. Given an integer n, he constructs an interval using the following method: he first generates a integer r between 1 and n (both inclusive) uniform-randomly, and then generates another integer l between 1 and r (both inclusive) uniform-randomly. The interval [l, r] is then constructed. Avin has constructed two intervals using the method above. He asks you what the probability that two intervals intersect is. You should print p* q(−1)(MOD 1, 000, 000, 007), while pq denoting the probability.

 

 

Input

Just one line contains the number n (1 ≤ n ≤ 1, 000, 000).

 

 

Output

Print the answer.

 

 

Sample Input

1

2

 

Sample Output

1

750000006

 

 

逆元主要用于求除法取模 即求(a/b)%p 的值

当p为素数时(例1e9+7)可以用费马小定理求逆元:  对于质数p,任意整数a,均满足:a^p≡a(mod p)

设整数为a,模数为 p,a在 mod p条件下的逆元为 x。

首先,我们由费马小定理得

  a^(p - 1) ≡ 1 mod p

变形得

  a * a^(p-2) ≡ 1 mod p

对比于逆元的定义

  a * x ≡ 1 mod p

显然 我们可以得到

  x ≡ a^(p-2) mod p

这样,我们就由费马小定理推理出 a 在 mod p 条件下的逆元为 a^(p-2)。

#include<bits/stdc++.h>
using namespace std;
const int mod=1e9+7;
long long n;
long long ksm(long long x,long long y)
{
	long long res=1;
	while(y)
	{
		if(y%2)
		{
			res=res*x%mod;
		}
		x=x*x%mod;
		y/=2;
	}
	return res;
}
int main()
{
	while(cin>>n)
	{
//找规律得出公式(n+1)/(2*n)%mod 使用逆元得 (n+1)* x %mod(x 为 2*n 的逆元)
		cout<<(n+1)*ksm(2*n,mod-2)%mod<<endl;
	}
	return 0;
}

 

 

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值