hdu6216 A Cubic number and A Cubic Number

A Cubic number and A Cubic Number

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 638    Accepted Submission(s): 319


Problem Description
A cubic number is the result of using a whole number in a multiplication three times. For example, 3×3×3=27 so 27 is a cubic number. The first few cubic numbers are 1,8,27,64 and 125 . Given an prime number p . Check that if p is a difference of two cubic numbers.
 

Input
The first of input contains an integer T (1T100) which is the total number of test cases.
For each test case, a line contains a prime number p (2p1012) .
 

Output
For each test case, output 'YES' if given p is a difference of two cubic numbers, or 'NO' if not.
 

Sample Input
  
  
10 2 3 5 7 11 13 17 19 23 29
 

Sample Output
  
  
NO NO NO YES NO NO NO YES NO NO
 

Source

2017 ACM/ICPC Asia Regional Qingdao Online 



k为素数,k为两立方数相减

将k分解因式,素数只能是1*本身的形式----------> k只能为相邻两个立方数的差


k=3b(b+1)-1

k-1=3b(b+1)

(k-1)/3=b(b+1)

筛选:3的倍数------->sqrt+floor  相邻两数之积


#include <iostream>
#include <stdio.h>
#include <math.h>
using namespace std;
int main()
{
	int t;
	long long p;
	long long temp;
	long long g;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lld",&p);
		if((p-1)%3!=0)
		{
			printf("NO\n");
			continue;
		}
		temp=(p-1)/3;
		g=floor(sqrt(temp));
		if(g*(g+1)==temp)
		{
			printf("YES\n");
		}
		else
		{
			printf("NO\n");
		}
	}
	return 0;
}
 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值