1010. Radix (25)
Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is "yes", if 6 is a decimal number and 110 is a binary number.
Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.
Input Specification:
Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N1 N2 tag radix
Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number "radix" is the radix of N1 if "tag" is 1, or of N2 if "tag" is 2.
Output Specification:
For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print "Impossible". If the solution is not unique, output the smallest possible radix.
Sample Input 1:6 110 1 10Sample Output 1:
2Sample Input 2:
1 ab 1 2Sample Output 2:
Impossible
这道题的代码我是在sunbaigui的程序基础上改动的,解题的话主要注意以下几个问题:
1)不能用int,否则会溢出,这里我用的是long long int。
2)在Compare函数中,如果sum比target大,要及时地返回,否则会有溢出的危险。
3)进制查找的最小值为字符串中最大的值+1,查找的最小值是待匹配的十进制数+1。
#include <stdio.h>
#include <string.h>
#define MAX 11
typedef long long int data;
int GetDigit(char *n, data i);
data GetNum(char *n, data radix);
data FindLeastRadix(char *n);
int Compare(char *n,data radix,data target);
data BinarySearch(char *n,data low,data high,data target);
int main()
{
char n1[MAX], n2[MAX];
data tag, radix;
data n;
data low, high, result;
scanf("%s %s %lld %lld", &n1, &n2, &tag, &radix);
if (tag == 1) {
n = GetNum(n1, radix);
low = FindLeastRadix(n2);
high = n + 1;
//high = n > low ? n + 1 : low + 1;
result = BinarySearch(n2, low, high, n);
}
else {
n = GetNum(n2, radix);
low = FindLeastRadix(n1);
high = n + 1;
//high = n > low ? n + 1 : low + 1;
result = BinarySearch(n1, low, high, n);
}
if (result == -1)
printf("Impossible");
else
printf("%lld", result);
return 0;
}
int GetDigit(char *n, data i)
{
if (n[i] >= '0'&&n[i] <= '9') {
return n[i] - '0';
}
else {
return n[i] - 'a' + 10;
}
}
data GetNum(char *n, data radix)
{
data sum = 0;
data len = strlen(n);
data x = 1;
for (data i = len - 1; i > -1; i--) {
int dig = GetDigit(n, i);
sum += dig*x;
x *= radix;
}
return sum;
}
data FindLeastRadix(char *n)
{
data len = strlen(n);
data least = 0;
for (data i = 0; i < len; i++) {
int digit = GetDigit(n, i);
if (digit >= least)
least = digit + 1;
}
return least;
}
int Compare(char *n, data radix, data target)
{
/*data len = strlen(n);
data sum = GetNum(n, radix);*/
data sum = 0;
data len = strlen(n);
data x = 1;
for (data i = len - 1; i > -1; i--) {
int dig = GetDigit(n, i);
sum += dig*x;
if (sum > target) //avoid over flow
return 1;
x *= radix;
}
if (sum > target)
return 1;
else if (sum < target)
return -1;
else
return 0;
}
data BinarySearch(char *n, data low, data high, data target)
{
data mid = low;
while (low <= high) {
int flag = Compare(n, mid, target);
switch (flag) {
case 1:
high = mid - 1;
break;
case -1:
low = mid + 1;
break;
case 0:
return mid;
}
mid = (high + low) >> 1;
}
return -1;
}