zoj2016Play on words(判断有向图是否存在欧拉回路通路)

Play on Words

Time Limit: 5 Seconds      Memory Limit: 32768 KB

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word "acm" can be followed by the word "motorola". Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.


Input

The input consists of T test cases. The number of them (T) is given on the first line of the input. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.


Output

Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.

If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.".


Sample Input

3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok


Sample Output

The door cannot be opened.
Ordering is possible.

The door cannot be opened.

题意是这样的:给出一组单词,看能否找到一组排列,使这组排列中的前一个单词的最后一个字母是后一个单词的第一个字母。

每个单词可以看成是连接首尾两个字母的一条边,这样可以统计处首尾各个单词所做点的出度和入度:

1.如果各个节点的出入度相同,则可以有欧拉回路;

2.若只有两个节点的出入度不同,且出入度之差为1和-1,则有欧拉通路。

其他情况则没有成立的可能……

#include<stdio.h>
#include<string.h>
struct edge{
    int u,v;
}edges[100005];
int out[26],in[26];
int used[26];
int n;
int parent[26];
char str[1005];
void UFset()
{
    for(int i=0;i<26;i++)
    parent[i]=-1;
}
int Find(int x)
{
    int s;
    for(s=x;parent[s]>=0;s=parent[s]);
    while(s!=x)
    {
        int temp=parent[x];
        parent[x]=s;
        x=temp;
    }
    return s;
}
void Union(int x1,int x2)
{
    int r1=Find(x1),r2=Find(x2);
    int temp=parent[r1]+parent[r2];
    if(parent[r1]<parent[r2])
    {
        parent[r2]=r1;
        parent[r1]=temp;
    }
    else
    {
        parent[r1]=r2;
        parent[r2]=temp;
    }
}
bool isconnect()
{
    int u,v,i;
    UFset();
    for(i=0;i<n;i++)
    {
        u=edges[i].u;v=edges[i].v;
        if(u!=v&&Find(u)!=Find(v))
        Union(u,v);
    }
    int first=-1;
    for(i=0;i<26;i++)
    {
        if(!used[i]) continue;
        if(first==-1) first=i;
        else if(Find(i)!=Find(first)) break;
    }
    if(i<26) return false;
    else return true;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(out,0,sizeof(out));
        memset(in,0,sizeof(in));
        memset(used,0,sizeof(used));
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%s",str);
            edges[i].u=str[0]-'a';  edges[i].v=str[strlen(str)-1]-'a';
            out[str[0]-'a']++;  in[str[strlen(str)-1]-'a']++;
            used[str[0]-'a']=1; used[str[strlen(str)-1]-'a']=1;
        }
        int judge1=0,judge2=0;
        bool flag1=true;
        for(int i=0;i<26;i++)
        {
            if(!used[i]) continue;
            if(out[i]-in[i]>=2||in[i]-out[i]>=2) {flag1=false;break;}
            if(out[i]==0&&in[i]==0) {flag1=false;break;}
            if(out[i]-in[i]==1)
            {  judge1++;
               if(judge1>1) {flag1=false;break;}
            }
            if(in[i]-out[i]==1)
            {  judge2++;
               if(judge2>1) {flag1=false;break;}
            }
        }
        if(judge1!=judge2) flag1=false;
        if(flag1==true&&isconnect())
        printf("Ordering is possible.\n");
        else
        printf("The door cannot be opened.\n");
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值