1020

Encoding

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 35505 Accepted Submission(s): 15704

Problem Description

Given a string containing only ‘A’ - ‘Z’, we could encode it using the following method:

  1. Each sub-string containing k same characters should be encoded to “kX” where “X” is the only character in this sub-string.

  2. If the length of the sub-string is 1, ‘1’ should be ignored.

Input

The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only ‘A’ - ‘Z’ and the length is less than 10000.

Output

For each test case, output the encoded string in a line.

Sample Input

2
ABC
ABBCCC

Sample Output
ABC
A2B3C


 这算是字符串合并吗,就是把连续的字符合在一起,就只用读数据的时候存储上一个字符和他重复的次数。
 1. 如果当前数与上一个相同,则重复的次数+1
 2. 如果当前数与上一个数不同,只用按题意输出上一个数,然后把记录的字符和次数改成当前字符的就行了

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

int main()
{
    freopen("input.txt","r",stdin);
    freopen("output.txt","w",stdout);
    int n;
    char a,b;
    int cnt;
    scanf("%d",&n);
    while(n--)
    {
        scanf(" %c",&b);cnt=1;
        while((a=getchar())!='\n'&&a!=EOF)
        {
            if(a==b)cnt++;
            else
            {
                if(cnt>1)printf("%d",cnt);
                putchar(b);
                cnt=1;
                b=a;
            }
        }
        if(cnt>1)printf("%d",cnt);
        putchar(b);
        putchar('\n');
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值