1022

Train Problem I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27777    Accepted Submission(s): 10522


Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
 

Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
 

Output
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
 

Sample Input
  
  
3 123 321 3 123 312
 

Sample Output
  
  
Yes. in in in out out out FINISH No. FINISH
Hint
Hint
For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".


    一道普通的搜索题(模拟??),维护一个栈,如果栈顶元素就是想要的,那只能选择出栈,否则如果还有元素没进栈,就只能选择入栈,同时记录答案就行

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <stack>

#define MAXN 15

using namespace std;

int n;
char o1[MAXN];
char o2[MAXN];
bool ans[2*MAXN];
stack<char>st;

bool work(int nown1,int nown2,int nows)//前nown1个元素已经进队,前nown2个元素已经出队,到了第nows步
{
    if(nown2==n)
    {
        printf("Yes.\n");
        for(int i=0;i<nows;i++)
        {
            if(ans[i])printf("in\n");
            else printf("out\n");
        }
        return true;
    }
    if(!st.empty()&&st.top()==o2[nown2])
    {
        st.pop();
        ans[nows]=false;
        if(work(nown1,nown2+1,nows+1))return true;
        st.push(o2[nown2]);
        return false;
    }
    if(nown1<n)
    {
        st.push(o1[nown1]);
        ans[nows]=true;
        if(work(nown1+1,nown2,nows+1))return true;
        st.pop();
    }
    return false;
}

int main()
{
    while(scanf("%d",&n)==1)
    {
        scanf("%s%s",o1,o2);
        if(!work(0,0,0))printf("No.\n");
        printf("FINISH\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值