1023

Train Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7259    Accepted Submission(s): 3906


Problem Description
As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.
 

Input
The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.
 

Output
For each test case, you should output how many ways that all the trains can get out of the railway.
 

Sample Input
  
  
1 2 3 10
 

Sample Output
  
  
1 2 5 16796
Hint
The result will be very large, so you may not process it by 32-bit integers.


    一道DP题,dp[i][j]表示入栈i次出栈j次的情况数

    dp[i][j]=dp[i-1][j]+dp[i][j-1];

    当然要始终保持i>=j>0;

    由于结果比较大,所以还要使用高精度


#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

#define MAXN 210

using namespace std;

struct longint{
    int num[MAXN];
    void operator=(int a)
    {
        num[0]=1;
        num[1]=a;
    }
    void operator+=(const longint &a)
    {
        int len=max(num[0],a.num[0]);
        for(int i=1;i<=len;i++)
        {
            if(i>num[0])num[i]=a.num[i];
            else if(i>a.num[0])break;
            else num[i]+=a.num[i];
        }
        num[0]=len;
        for(int i=1;i<num[0];i++)
        {
            if(num[i]>=10)
            {
                num[i]-=10;
                num[i+1]++;
            }
        }
        if(num[num[0]]>=10)
        {
            num[num[0]]-=10;
            num[0]++;
            num[num[0]]=1;
        }
    }
    void print()
    {
        for(int i=num[0];i;i--)putchar(num[i]+'0');
    }
};

int n,m;
longint dp[MAXN][MAXN];

int main()
{
    while(scanf("%d",&n)==1)
    {
        m=n<<1;
        dp[0][0]=1;
        for(int k=1;k<=m;k++)//第k步
        {
            for(int i=k,j=0;i>=j;i--,j++)//入栈i次,出栈j次
            {
                dp[i][j]=0;
                if(i>j)dp[i][j]+=dp[i-1][j];
                if(j)dp[i][j]+=dp[i][j-1];
            }
        }
        dp[n][n].print();
        putchar('\n');
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值