HDU 1016 Prime Ring Problem

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input

n (0 < n < 20).
 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input

  
  
6 8
 

Sample Output

  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2

典型的DFS,先打一个素数表,相邻两个之和为素数即可,代码如下


#include<iostream>
#include<string.h>
using namespace std;
int n,a[15],circle[21];//一个素数表,一个圈 
int judge(int k,int b[],int l)//判断k是否在b的前l中 
{
	for(int i=1;i<l;i++)
		if(b[i]==k)
			return 1;
	return 0;
}
void dfs(int k)
{
	int i;
	if(k>n)
	{
		for(i=1;i<=n;i++)
		{
			if(i!=1)
				cout<<" ";
			cout<<circle[i];
		}
		cout<<endl;
	}
	if(n==k)
	{
		for(i=2;i<=n;i++)
		{
			if((!judge(i,circle,k))&&judge(circle[k-1]+i,a,13)&&judge(i+1,a,13))//寻找一个没有出现的且与前后相加都为素数的i 
			{
				circle[k]=i;
				dfs(k+1);
			}
		}
	}
	if(k<n)
	{
		for(i=2;i<=n;i++)
		{
			if((!judge(i,circle,k))&&judge(circle[k-1]+i,a,13))//寻找一个只与前面相加为素数的i 
			{
				circle[k]=i;
				dfs(k+1);
			}
		}
	}
}
int main()
{
	int i,j,k,flag;
	a[1]=2;
	j=2;
	for(i=3;i<=40;i++)//素数表。 
	{
		flag=0;
		for(k=2;k<i;k++)
		{
			if(i%k==0)
			{
				flag=1;
				break;
			}
		}
		if(flag==0) a[j++]=i;
	}
	j=1;
	while(cin>>n)
	{
		memset(circle,0,sizeof(circle));
		circle[1]=1;
		cout<<"Case "<<j++<<":"<<endl;
		dfs(2);
		cout<<endl;	
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值