1011 of greedy strategy

Problem Description
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


 

Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. <br> <br>The input is terminated by a line containing pair of zeros <br>
 

Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
 

Sample Input
  
  
3 2 1 2 -3 1 2 1 1 2 0 2 0 0
 

Sample Output
  
  
Case 1: 2 Case 2: 1
 

 题目要求:提供雷达半径和小岛位置坐标,计算最少的数目的雷达覆盖所有的小岛,若不能覆盖则输出-1.

题目思路:1进行输入的时候进行一次判断,若纵坐标大于雷达半径则标记。若已经标记则直接输出-1,否者算出每个小岛在x轴那些范围的雷达可以检测,把每组的开始坐标进行排序,然后从最小进行求最大重叠区间,当没有重叠则计数加一并将区间变成下一组,最后输出计数。

细节:保存区间时要用double类型储存。

#include <cstdio>
#include<iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<map>
#include<set>
#include<vector>
using namespace std;
struct dao
{
    double left;
    double right;
};
bool cmp(const dao &a,const dao &b)
{
    if(a.left<=b.left) return true;
    return false;
}
int main()
{
    dao ww[1000];
    int n,d,i,l;
    int x,y,t,k,e=1;
    double L,R,a;
    while(cin>>n>>d&&n!=0||d!=0)
    {
        t=1;l=1;
        for(i=0;i<n;i++)
        {
            cin>>x>>y;
            if(d>=y&&l)
            {
                ww[i].left=x-sqrt(d*d-y*y);
                ww[i].right=x+sqrt(d*d-y*y);
            }
            else l=0;
        }
        if(!l)
        {
            cout<<"Case "<<e++<<": -1"<<endl;
            continue;
        }
        sort(ww,ww+n,cmp);
        R=ww[0].right;
        for(k=1;k<n;k++)
        {
            if(ww[k].left>R)
            {
                t++;
                R=ww[k].right;
            }
            else if(ww[k].right<=R)
                {
                    R=ww[k].right;
                }
        }
        cout<<"Case "<<e<<": "<<t<<endl;
        e++;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值