1020 of search

Prime Ring Problem

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 27   Accepted Submission(s) : 17
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.<br><br>Note: the number of first circle should always be 1.<br><br><img src=../../data/images/1016-1.gif><br>
 

Input
n (0 < n < 20).<br>
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.<br><br>You are to write a program that completes above process.<br><br>Print a blank line after each case.<br>
 

Sample Input
  
  
6<br>8<br>
 

Sample Output
  
  
Case 1:<br>1 4 3 2 5 6<br>1 6 5 2 3 4<br><br>Case 2:<br>1 2 3 8 5 6 7 4<br>1 2 5 8 3 4 7 6<br>1 4 7 6 5 8 3 2<br>1 6 7 4 3 8 5 2<br>
 

Source
Asia 1996, Shanghai (Mainland China)
 题目要求:给你一个数n,把1到n进行排列,使每个数的前后都与这个数相加都为素数,第一个为1固定。
 解题思路:因为n小于20,所以所以的数最大不会超过40,将40内的素数进行打表,然后进行dfs进行搜索排序,但需要对已经选过的组合进行标记,出口为当全部排完或者新的数不为素数跳出.
#include<iostream>
#include<cstdio>
#include<string.h>
using namespace std;
int num[21],mark[21],n;
int prime_num[12] = {2,3,5,7,11,13,17,19,23,29,31,37};
int is_prime(int a)
{
    for(int i = 0; i < 12;i++)
    if(a==prime_num[i])return 1;
    return 0;
}
void print_num()
{
    for(int i=1;i<n;i++)
        printf("%d ",num[i]);
        printf("%d",num[n]);
}
int dfs(int pre,int post,int flag)
{
    if(!is_prime(pre+post))
        return 0;
    num[flag]=post;
    if(flag==n&&is_prime(post+1))
    {
        print_num();
        printf("\n");
        return 1;
    }
    mark[post]=0;
    for(int i=2;i<=n;i++)
        if(mark[i]!=0&&dfs(post,i,flag+1)){break;}
    mark[post]=1;
    return 0;
}
int main()
{
    int count;
    count=1;
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
        mark[i]=i;
        num[1]=1;
        printf("Case %d:\n",count++);
        if(n==1)printf("1\n");
        for(int i=2;i<=n;i++)
            dfs(1,i,2);
        printf("\n");
    }
        return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值