POJ 2184 【01背包问题负权变体】

变化的01背包

题目描述:
题目:Cow Exhibition
Description

“Fat and docile, big and dumb, they look so stupid, they aren’t much
fun…”

  • Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si’s and, likewise, the total funness TF of the group is the sum of the Fi’s. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.
Input

  • Line 1: A single integer N, the number of cows

  • Lines 2…N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.
    Output

  • Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5
Sample Output

8
Hint

OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value
of TS+TF to 10, but the new value of TF would be negative, so it is not
allowed.

思路解法:
这道题我们可以用01背包的思路来解,我其实一开始也没看出来,但是后来发现我们可以将smartness想象成物品重量,将funness想象成物品的价值,用01的板子求出对应的dp[i],即取i件物品的最大价值,最后我们再遍历重量,求出重量与价值的最大和。这里注意,有负值。对于负的重量,我们采用逆序的循环来写背包。因为,减去一个负值即加上一个正值,因此我们要反向更新它的值,注意是从0开始的。又由于价值存在为负的情况,故初始化不再是简单的赋值为0,而是初始化为负无穷。由于负的地址作为数组下标,没有意义,所以我们采用移位的思想控制下标,当然不是真的移位,只是取中间一个数m,m的绝对值大于任何一个w和v,将它初始化为0。
完整代码展示:

#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define N 200005 //The max possible value
#define M 10005  //The shift position
const int inf=0x3f3f3f3f;
int v[N],w[N],dp[N];
int main(){
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++) scanf("%d%d",&w[i],&v[i]);
    fill(dp,dp+N,-inf);  //Initial the dp number groups
    dp[M]=0;   //The value of shift position
    for(int i=0;i<n;i++){
        if(w[i]>=0){
            for(int j=N-1;j>=w[i];j--) dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
        }
        else{
            for(int j=0;j<N+w[i];j++) dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
        }
    }
    int ans=0;
    for(int i=M;i<=N;i++){
        if(dp[i]>0) ans=max(ans,dp[i]+i-M);  //Find the max value of TS&TF which is not less than 0
    }
    cout<<ans;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

tran_sient

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值