HDU2054 A == B?

Problem Description
Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
 

Input
each test case contains two numbers A and B.
 

Output
for each case, if A is equal to B, you should print "YES", or print "NO".
 

Sample Input
  
  
1 2 2 2 3 3 4 3
 

Sample Output
  
  
NO YES YES NO
#include<iostream>
#include<cstring>
using namespace std;
char a[100000],b[100000];

bool is(char*p)
{
	for(;*p!='\0';p++)
		if(*p=='.')
			return 1;
	return 0;
}

void det(char *p)
{
	for(;*p!='\0';p++)
		;
	p--;
	for(;*p=='0';p--)
		*p ='\0';
	if(*p=='.')
		*p='\0';
}

int main()
{
	while(scanf("%s%s",a,b)!=EOF)
	{
		if(is(a))
			det(a);
		if(is(b))
			det(b);
		if(strcmp(a,b)==0)
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值