HDU2371 Decode the Strings 【找规律】

Decode the Strings

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 800    Accepted Submission(s): 244

Problem Description
Bruce Force has had an interesting idea how to encode strings. The following is the description of how the encoding is done:
Let x1,x2,...,xn be the sequence of characters of the string to be encoded.

1. Choose an integer m and n pairwise distinct numbers p1,p2,...,pn from the set {1, 2, ..., n} (a permutation of the numbers 1 to n).
2. Repeat the following step m times.
3. For 1 ≤ i ≤ n set yi to xpi, and then for 1 ≤ i ≤ n replace xi by yi.

For example, when we want to encode the string "hello", and we choose the value m = 3 and the permutation 2, 3, 1, 5, 4, the data would be encoded in 3 steps: "hello" -> "elhol" -> "lhelo" -> "helol". 

Bruce gives you the encoded strings, and the numbers m and p1, ..., pn used to encode these strings. He claims that because he used huge numbers m for encoding, you will need a lot of time to decode the strings. Can you disprove this claim by quickly decoding the strings?

Input
The input contains several test cases. Each test case starts with a line containing two numbers n and m (1 ≤ n ≤ 80, 1 ≤ m ≤ 109). The following line consists of n pairwise different numbers p1,...,pn (1 ≤ pi ≤ n). The third line of each test case consists of exactly n characters, and represent the encoded string. The last test case is followed by a line containing two zeros.
 
Output
For each test case, print one line with the decoded string.
 
Sample Input
  
  
5 3 2 3 1 5 4 helol 16 804289384 13 10 2 7 8 1 16 12 15 6 5 14 3 4 11 9 scssoet tcaede n 8 12 5 3 4 2 1 8 6 7 encoded? 0 0
 
Sample Output
  
  
hello second test case encoded?
 找每个字符的循环节
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int num[100];
int n1[100][100];
int n,m;
char str[100];
char ans[100];
int main()
{
	int i,j;
	int a,b;
	int count;
	while(~scanf("%d%d",&n,&m),n||m)
	{
		memset(str,0,sizeof(str));
		memset(ans,0,sizeof(ans));
		for(i=0;i<n;i++)
		{
			scanf("%d",&num[i]);
			num[i]--;
		}
		getchar();
		gets(str);
		for(i=0;i<n;i++)
		{
			count=0;
			a=num[i];
			n1[i][count++]=i;
			while(a!=i)
			{
				n1[i][count++]=a;
				a=num[a];
			}
			b=m%count;
			ans[n1[i][b]]=str[i];
		}
		ans[n]=='\0';
		puts(ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值