解决Ubuntu升级12.10后无法编码Android源码问题

因为gnome3.4版本有很多Bug,无法正常使用,所以将Ubuntu12.04 LTS升级到了12.10来使用gnome3.6.

升级之后就悲剧了.虽然gnome3.6正常工作了,但原先的android2.3代码无法编译通过了。后来经过探索,发现是由于12.10的编译工具太新的缘故...囧

12.10的gcc版本为4.7, g++版本为4.7,JDK版本为1.7,而android不支持高版本的编译器,因此无法正常编译了。


解决方案如下:

1.gcc降级成4.4    g++降级成4.4

sudo apt-get install gcc-4.4 g++-4.4 g++-4.4-multilib gcc-4.4-multilib
sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.4 50
sudo update-alternatives --install /usr/bin/g++ g++ /usr/bin/g++-4.4 50

配置选择那个版本

sudo update-alternatives --config g++
sudo update-alternatives --config gcc

徐选择相应的版本即可


2.JDK降级成1.6

sudo apt-get install openjdk-6-jdk
sudo apt-get install openjdk-6-jre

通过以下方式切换:

sudo update-alternatives --config java
sudo update-alternatives --config javac

切换完成后使用

java -version
javac -version

确认一下版本信息是否正确即可

发布了2 篇原创文章 · 获赞 0 · 访问量 1866
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 大白 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览