Immediate Decodability HDU - 1305(字典树)

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:
A:01 B:10 C:0010 D:0000

but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input

Write a program that accepts as input a series of groups of records from input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

Sample Input

01
10
0010
0000
9
01
10
010
0000
9

Sample Output

Set 1 is immediately decodable
Set 2 is not immediately decodable

题目是英文的,就说一下题意吧,就是先给一堆一堆的串(不遇到9的话,就一直输入),等到9时,如果输入的这些串中有的串是其他串的前缀时,这时就不能立即编码,只有没有前缀时,才能立即编码。也是字典树,在输入的过程中就开始判断是不是已经出现了前缀。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<bits/stdc++.h>
using namespace std;
const int maxn=10000; 
typedef long long ll;

char s[maxn];
int tree[maxn][30];
int tot;
bool vis[maxn];
bool flag;

void insert(char *a)
{
	int root=0;
	
	for(int i=0;i<strlen(a);i++)
	{
		int x=a[i]-'0';
		if(!tree[root][x])
			tree[root][x]=++tot;
		 root=tree[root][x];	 
		if(vis[root])
			flag=false;		//判断前缀的 
	}
	
	if(vis[root])
		flag=false;
	else	
		vis[root]=true;
}
int main()
{
	flag=true;
	int kase=0;
	while(scanf("%s",s)!=EOF)
	{
		if(s[0]=='9')
		{
			if(flag)
				printf("Set %d is immediately decodable\n",++kase);
			else
				printf("Set %d is not immediately decodable\n",++kase);
			tot=0;
			flag=true;
			memset(tree,0,sizeof(tree));
			memset(vis,false,sizeof(vis));
		}
		
		else
		{
			insert(s);
		}		
		
	}	
	return 0;
}

一些字典树的基本操作就不说了,就是函数里面的那堆模板。

void insert(char *a)
{
	int root=0;
	
	for(int i=0;i<strlen(a);i++)
	{
		int x=a[i]-'0';
		if(!tree[root][x])
			tree[root][x]=++tot;
		 root=tree[root][x];	 
		if(vis[root])
			flag=false;		//判断前缀的 
	}
	
	if(vis[root])
		flag=false;
	else	
		vis[root]=true;
}

在这里面判断是否出现前缀是通过一个  bool vis[maxn] 数组来判断,在不断的插入字符串操作中将各个前缀的root 都标记成true,在下次再来一个相同的前缀时,就会flag =false 。在主函数 里面在判断一下,初始化一下 ,就可以判断了 。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值