ACM书中的题目 L-12

L-12

Input Specification

The input contains several test cases. The first line contains an integer specifying the number of test cases. Each test case consists of a single line of text which contains at most 70 characters. However, the newline character at the end of each line is not considered to be part of the line.

Output Specification

For each test case, print a line containing the characters of the input line in reverse order.

Sample Input

3
Frankly, I don’t think we’ll make much
money out of this scheme.
madam I’m adam

Sample Output

hcum ekam ll’ew kniht t’nod I ,ylknarF
.emehcs siht fo tuo yenom
mada m’I madam

题目简述:
大体意思就是输入一串字符,然后反向输出
解题思路:
使用String变量解决(char也可以),但是要注意回车键的储存,不然会出现两个空行
题目细节:
就是思路里所说的回车键问题
代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n,sum;
    char c;
    string str;
    cin>>n;
    cin.get(c);
    for(int i=0;i<n;i++)
    {
        getline(cin,str);
        sum=str.size();
        for(int t=sum-1;t>=0;t--)
        {
            cout<<str[t];
        }
        cout<<endl;
    }
}

体会:
一开始发现回车键这个问题时相当难受,不知道怎么解决,还是上网查了一下才知道回车键要用char来储存,知道的还是太少了

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值