Input Specification:
Each input file contains one test case. For each test case, the first line contains two positive integers: N (<= 50000), the total number of queries, and K (<= 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing -- for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.
Output Specification:
For each case, process the queries one by one. Output the recommendations for each query in a line in the format:
query: rec[1] rec[2] ... rec[K]
where query is the item that the user is accessing, and rec[i] (i = 1, ... K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.
Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.
Sample Input:
12 3
3 5 7 5 5 3 2 1 8 3 8 12
Sample Output:
5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8
第一次知道set也可以内部排序,,想用queue写来着,但是queue不能内部查找和删除,,所以,,放弃了。。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <set>
#include <map>
using namespace std;
struct node
{
int cnt;
int val;
bool operator<(const node &a)const
{
if(cnt==a.cnt)
return val<a.val;
else
return cnt>a.cnt;
}
};
int n,k;
int a[50005];
int b[50005];
set <node> s;
int main()
{
int i,j,x;
node p;
scanf("%d%d",&n,&k);
for(i=0; i<n; i++)
{
scanf("%d",&x);
if(i>0)
{
printf("%d:",x);
set<node>::iterator it;
int cnt=0;
for(it=s.begin(); it!=s.end()&&cnt<k; it++)
{
cnt++;
printf(" %d",it->val);
}
printf("\n");
}
p.cnt=b[x];
b[x]++;
p.val=x;
if(s.find(p)!=s.end())//每次判断是否已经出现过了,如果有,则删除后再更新,若没有,则直接更新
s.erase(p);
p.cnt++;
s.insert(p);
}
return 0;
}