CMake升级安装版本3.17以上

1.前期准备

# 检查cmake版本
$ cmake --version
# 安装编译依赖
sudo yum install -y gcc gcc-c++ build-essential autoconf libtool pkg-config

本文最新状态可查看源站链接:CMake升级安装版本3.17以上

2. 快捷安装

在Linux下, 现有系统级别的cmake版本太低,可以通过一下脚本在本地目录安装更新的cmake版本。

$ wget -q -O cmake-linux.sh https://github.com/Kitware/CMake/releases/download/v3.17.0/cmake-3.17.0-Linux-x86_64.sh
$ sh cmake-linux.sh -- --skip-license --prefix=/usr
$ rm cmake-linux.sh

3. 二进制包安装

# 下载二进制包
wget https://github.com/Kitware/CMake/releases/download/v3.18.2/cmake-3.18.2-Linux-x86_64.tar.gz
tar zxvf cmake-3.18.2-Linux-x86_64.tar.gz
cd cmake-3.18.2
# 将文件夹内容拷贝到默认环境变量路径下,例如/usr

4. 源码安装

wget -O cmake-3.18.2.tar.gz  https://github.com/Kitware/CMake/releases/download/v3.18.2/cmake-3.18.2.tar.gz
tar zxvf cmake-3.18.2.tar.gz
cd cmake-3.18.2
  • 如果现有系统无cmake
./bootstrap
make
make install
  • 如果现有系统有cmake
cmake -DCMAKE_INSTALL_PREFIX=/usr .
make
make install
©️2020 CSDN 皮肤主题: 技术黑板 设计师:CSDN官方博客 返回首页