PAT (Advanced Level) 1063. Set Similarity (25) set的相似度

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:
3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3
Sample Output:
50.0%
33.3%
判断两个set的相似度。
/*2015.7.28cyq*/
#include <iostream>
#include <vector>
#include <set>
#include <fstream>
using namespace std;

//ifstream fin("case1.txt");
//#define cin fin

double f(const set<int> &a,const set<int> &b){
	double n1=a.size();
	double n2=b.size();
	int count=0;
	for(auto it=a.begin();it!=a.end();it++){
		if(b.find(*it)!=b.end()){//共有元素
			count++;
		}
	}
	return count/(n1+n2-count)*100;
}

int main(){
	int N;
	cin>>N;
	set<int> level;
	vector<set<int> > datas;
	int M,x;
	while(N--){
		cin>>M;
		while(M--){
			cin>>x;
			level.insert(x);
		}
		datas.push_back(level);
		level.clear();
	}

	int K;
	cin>>K;
	int a,b;
	while(K--){
		cin>>a>>b;
		printf("%.1f%%\n",f(datas[a-1],datas[b-1]));
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值