输入一行字符,分别统计出包含英文字母、空格、数字和其它字符的个数

题目描述:

输入一行字符,分别统计出包含英文字母、空格、数字和其它字符的个数。

    /**
     * 统计出英文字母字符的个数。
     * 
     * @param str 需要输入的字符串
     * @return 英文字母的个数
     */
    public static int getEnglishCharCount(String str)
    {
        return 0;
    }
    
    /**
     * 统计出空格字符的个数。
     * 
     * @param str 需要输入的字符串
     * @return 空格的个数
     */
    public static int getBlankCharCount(String str)
    {
        return 0;
    }
    
    /**
     * 统计出数字字符的个数。
     * 
     * @param str 需要输入的字符串
     * @return 英文字母的个数
     */
    public static int getNumberCharCount(String str)
    {
        return 0;
    }
    
    /**
     * 统计出其它字符的个数。
     * 
     * @param str 需要输入的字符串
     * @return 英文字母的个数
     */
    public static int getOtherCharCount(String str)
    {
        return 0;

    }

知识点: 字符串

输入: 输入一行字符串,可以有空格

输出: 统计其中英文字符,空格字符,数字字符,其他字符的个数

样例输入: 1qazxsw23 edcvfr45tgbn hy67uj m,ki89ol.\\/;p0-=\\][

样例输出: 26 3 10 12

代码:

#include <iostream>
#define MAX 1000
using namespace std;
int main()
{
	char str[MAX];
	cin.getline(str, MAX);
	int len = strlen(str);
	int ch = 0, sp = 0, nu = 0, oth = 0, i;
	for (i = 0; i<len; i++)
	{
		if ((str[i] >= 'a'&&str[i] <= 'z') || (str[i] >= 'A'&&str[i] <= 'Z'))
			ch++;
		else if (str[i] >= '0'&&str[i] <= '9')
			nu++;
		else if (str[i] == ' ')
			sp++;
		else
			oth++;
	}
	cout << ch << endl << sp << endl << nu << endl << oth << endl;
//	cin.get();
//	cin.get();
	return 0;
}
得分运行时间内存复杂度最大嵌套深度
100(100)16ms2052KB103

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值