loadrunner支持的浏览器版本

LoadRunner支持的IE版本

8.0 最高ie6
8.1 最高ie6
9.0 最高ie7
9.5 最高ie8
11.0 最高ie9( win7 32位+LR11+IE10可用,但win7 64位+LR11+IE10不可用,降至IE9可用),支持firefox3.6、24.0

(LoadRunner11 支持哪个版本的Firefox?最新到哪个版本?

您可以在:http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/ 下载24.0版本,这个版本可以确定支持。火狐企业平台



       性能测试没必要在浏览器上纠结,浏览器不同版本,什么IE、谷歌、火狐、opera,这些在性能测试上没有什么区别,浏览器唯一使用到就是可以进行脚本录制,但是后面的场景设置、场景加压浏览器的版本是起不到任何什么作用的,目前还没发现不同版本浏览器对性能测试结果有什么很大的影响,可能有但微乎其微。要明白性能测试的目的是什么,是如何模拟真实的场景对系统进行加压、了解系统响应情况,对性能问题进行排查和调优。因为在功能测试上是对浏览器有要求,毕竟不同浏览器对功能展现、界面甚至功能都有影响,但性能测试不同于功能测试,可以不用去纠结界面是否错位、样式问题,我们关注的是可以向服务器发送请求,加压。
       经常性的看到有人提出各种LR和IE版本无法兼容,而不停的去解决如何进行兼容,为什么你不根据LR版本而去选择合适的IE版本,比如用LR8.0,一直纠结去解决如何兼容IE7,这无非是去浪费时间,这不是压力负载测试中我们需要花时间去考虑的问题。
       所以我觉得在使用LR时,先看看项目要求的浏览器能不能录制脚本,若不能,直接换成IE6(LR8.1最高只能支持IE 6)录制脚本,毕竟要的也是只要有了脚本就可以,后面的场景加压还需要考虑浏览器版本吗?不需要。就如同,如果能力强,可以不要浏览器来录制,自己手动写测试脚本是一样的。

阅读更多
个人分类: 服务器
上一篇loadrunner11 运行场景报错 兼容性问题
下一篇修改Apache的最大连接数
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭