How Many Tables 并查集

这个并查集题是认识的人可以坐在一个桌子上,比如a认识b,b认识c,那么a,b,c可以在一个桌子上 这个题可以这么想把在一个桌子上的人全在一起 那么合并到这个人的那个人的根节点会改变 比如 a合并到b上,那么a的根节点就连到b的根节点上  a的根节点值就改变了  后面只需要检测根节点和初始赋值是否相同 找到不相同的 用总的桌子书减去就是我们要的结果

Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.


One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.


For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

 

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

 

Sample Input

25 31 22 34 55 12 5

 

Sample Output

24
#include <iostream>
#include <cstdio>
#include <cstring>
#define N 1050
using namespace std;

int par[N];
int fond(int x)//查找根
{
    return x == par[x] ? x :fond(par[x]);
}
void unionn(int x, int y)//合并两个数
{
    int root1,root2;
    root1 = fond(x);
    root2 = fond(y);
    if(root1 != root2)
    {
        par[root2] = root1;//合并
    }
}

struct node
{
    int x;
    int y;
};

int main()
{
    int t,n,m;
    node p;
    scanf("%d",&t);
    while(t -- )
    {
        memset(par,0,sizeof(par));
     scanf("%d%d",&n,&m);
     for(int i = 0; i < n ; i ++)
     {
         par[i]=i;
     }
     for(int i = 0; i < m; i ++)
     {
         scanf("%d%d",&p.x,&p.y);
         unionn(p.x,p.y);
     }
     int sum = n;
     for( int i = 0; i < n; i++)
     {
         if(par[i] != i)
            sum --;

     }
     printf("%d\n",sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值