2016ACM/ICPC亚洲区大连站 D - A Simple Math Problem(尚未通过)

Given two positive integers a and b,find suitable X and Y to meet the conditions:
X+Y=a
Least Common Multiple (X, Y) =b

Input

Output
For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of “No Solution”(without quotation).

Sample Input
6 8
798 10780
Sample Output
No Solution
308 490

#include<iostream>
#include<cmath>
#include<cstdio>

using namespace std;
long long gcd(long long a,long long b);
long long lcm(long long a,long long b);

int main(){
    long long a,b;

    while(cin >> a >> b){
        int temp = gcd(a,b);
        long long x,y;
        if(a*a > 4*b*temp){
            x = (a + sqrt(a*a - 4*b*temp))/2;
            y = a-x;
            if(x+y == a && lcm(x,y) == b)
                printf("%d %d\n",x,y);
            else
                cout << "No Solution" << endl;
        }
        else{
            cout << "No Solution" << endl;
        }
    }

    return 0;
}

long long gcd(long long a,long long b){
    return b == 0 ? a : gcd(b,a%b);
}

long long lcm(long long a,long long b){
    return a*b/gcd(a,b);
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值