2016ACM/ICPC亚洲区大连站 J - Find Small A

As is known to all,the ASCII of character ‘a’ is 97. Now,find out how many character ‘a’ in a group of given numbers. Please note that the numbers here are given by 32 bits’ integers in the computer.That means,1digit represents 4 characters(one character is represented by 8 bits’ binary digits).

Input
The input contains a set of test data.The first number is one positive integer N (1≤N≤100),and then N positive integersai (1≤ aiai≤2^32 - 1) follow

Output
Output one line,including an integer representing the number of ‘a’ in the group of given numbers.

Sample Input
3
97 24929 100
Sample Output
3

不需要转换为二进制,直接进行位运算再和‘255’即‘11111111’进行与运算。

#include<cstdio>
#include<iostream>
#include<math.h>

using namespace std;
int f(int num);
long long p = pow(2,8) - 1;

int main(void){
    int num;
    while(cin >> num){
        int ans = 0;

        for(int i = 0;i < num;i++){
            long long temp;
            cin >> temp;
            ans += f(temp);
        }

        cout << ans << endl;
        }
    return 0;
}

int f(int num){
    int ans2 = 0;
    long long temp;
    int j = 0;
    while(j < 4){
        int k = j*8;
        j++;
        temp = num >> k;
        temp = temp & p;
        if(temp == 97)
            ans2 ++;
    }
    return ans2;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值