POJ_2485 Highway_Kruskal

5 篇文章 0 订阅



2485:Highway

总时间限制: 

1000ms 

内存限制: 

65536kB

 

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

输入

The first line of input is an integer T, which tells how many test cases followed.
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.

输出

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

样例输入

1

3
0 990 692
990 0 179
692 179 0

样例输出

692

提示

Huge input,scanf is recommended.

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

typedef struct edge
{
	int start;
	int end;
	int weight;
}Edge;


#define MAXN 500		//点的数量
#define MAXM 250000		//边的数量
#define INF 100000
//最小生成树

class MST
{
public:
	MST(int num):m(0),n(num){
	}
	void Add_Edge(int start, int end, int weight){
		m++;
		E[m].start = start;
		E[m].end = end;
		E[m].weight = weight;
	}
	void MST_Kruskal();			//Kruskal最小生成树算法
private:
	int n;			//点的数量
	int m;			//边的数量
	Edge E[MAXM+4];
//并查集
public:
	int p[MAXN+4];
	int rank[MAXN+4];
	void Make_Set(int x);
	void Union(int x, int y);
	void Link(int x, int y);
	int Find_Set(int x);
};

//排序函数
bool cmp(Edge a, Edge b){
	return a.weight< b.weight;
}

void MST::MST_Kruskal(){
	int u,v;
	int len;
	int max = -INF;
	//for each vetrex v∈V[G] do Make_Set(v)
	for(int i =1; i<=n; i++)
		MST::Make_Set(i);
	sort(E+1,E+m+1,cmp);
	for(int i=1; i<=m; i++){
		u = E[i].start, v = E[i].end;
		len = E[i].weight;
		if(Find_Set(u) != Find_Set(v)){
			//把边E[i]加入到最小生成树中
			//cout<<u<<" "<<v<<" "<<len<<endl;
			if(len > max)
				max = len;
			Union(u,v);
		}
	}
	cout<<max<<endl;
}

//并查集操作
void MST::Make_Set(int x){
	p[x] = x;
	rank[x] = 0;
}


void MST::Union(int x, int y){
	Link(Find_Set(x),Find_Set(y));
}

void MST::Link(int x, int y){
	if(rank[x] > rank[y]){
		p[y] = x;
	}
	else{
		p[x] = y;
		if(rank[x] == rank[y])
			rank[y]++;
	}
}

int MST::Find_Set(int x){
	if(x != p[x])
		p[x] = Find_Set(p[x]);
	return p[x];
}

//#define UNSUBMIT
int main(){
#ifdef UNSUBMIT
	freopen("a.in","r",stdin);
#endif
	int T;
	int n;				//输入点,边的数量
	int temp;				//暂存的边权值
	//int start,end,weight;
	MST *t;

	scanf("%d",&T);
	while(T)
	{
		scanf("%d",&n);
		t = new MST(n);
		for(int i=1; i<=n; i++)
		{
			for(int j=1; j<=n; j++)
			{
				scanf("%d",&temp);
				if(temp != 0)
					t->Add_Edge(i,j,temp);
			}
		}
		t->MST_Kruskal();
		T--;
	}

	
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值