Legal or Not HDU

                                                             Legal or Not

                Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                Total Submission(s): 3060    Accepted Submission(s): 1386


Problem Description
          ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

        We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

       Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.
 


 

Input
      The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
 


 

Output
     For each test case, print in one line the judgement of the messy relationship.
     If it is legal, output "YES", otherwise "NO".
 


 

Sample Input
  
  
3 2 0 1 1 2 2 2 0 1 1 0 0 0
 


 

Sample Output
  
  
YES NO

 

 

题意:

    题目意思很简单,就是给你几组数据叫你判断他们之间是否形成一个环。只是这题有一点很恶心,就是要判断重边。但是如果用下面的简单版的代码的话,就可以直接忽略重边问题了。但是如果用到了翻译版的拓扑算法的话就可怜了。。。。。但也是可以解决问题的,方法就是下面的复杂版。不说太多了,自己看下面的代码吧,如有疑问或者文中如有错误欢迎指出,共同进步。

 

 

简单版

#include <stdio.h>
#include <string.h>

const int MAX = 100 + 10;
int n,m,G[MAX][MAX],c[MAX];
bool DFS(int u)
{
    c[u] = -1;
    for(int v = 0;v < n;v++)if(G[u][v])
    {
        if(c[v]<0) return false;
        if(!c[v]&&!DFS(v)) return false;
    }
    c[u] = 1;
    return true;
}
bool TopSort()
{
    memset(c,0,sizeof(c));
    for(int v = 0;v < n;v++)if(!c[v])
      if(!DFS(v)) return false;
    return true;
}
int main()
{
    while(scanf("%d%d",&n,&m),n)
    {
        int x,y;
        memset(G,0,sizeof(G));
        for(int i = 0;i < m;i++)
        {
            scanf("%d%d",&x,&y);
            G[x][y] = 1;
        }
        if(TopSort())
          printf("YES\n");
        else
          printf("NO\n");
    }
    return 0;
}

 

 


复杂版(邻接表)

#include <iostream>
#include <cstdlib>
#include <queue>
using namespace std;

const int MaxVertexNum = 100;
typedef int VertexType;
typedef struct node
{
    int adjvex;
    node* next;
}EdgeNode;
typedef struct
{
    VertexType vertex;
    EdgeNode* firstedge;
    int count;
}VertexNode;
typedef VertexNode AdjList[MaxVertexNum];
typedef struct
{
    AdjList adjlist;
    int n,e;
}ALGraph;
bool CreatALGraph(ALGraph *G)
{
    int i,j,k;
    EdgeNode* s;
    cin>>G->n>>G->e;
    if(G->n == 0)
      return false;
    for(i = 0;i < G->n;i++)
    {
        G->adjlist[i].vertex = i;
        G->adjlist[i].firstedge = NULL;
    }
    for(k = 0;k < G->e;k++)
    {
        cin>>i>>j;
        s = (EdgeNode *)malloc(sizeof(EdgeNode));
        s->adjvex = j;
        s->next = G->adjlist[i].firstedge;
        G->adjlist[i].firstedge = s;
    }
    return true;
}

void TopSort(ALGraph *G)
{
    EdgeNode *p;
    queue<int> Q;
    int i,j,cnt = 0;
    for(i = 0;i < G->n;i++)
      G->adjlist[i].count = 0;
    for(i = 0;i < G->n;i++)
    {
        p = G->adjlist[i].firstedge;
        while(p != NULL)
        {
            G->adjlist[p->adjvex].count++;
            p = p->next;
        }
    }
    for(i = 0;i < G->n;i++)
      if(G->adjlist[i].count == 0)
        Q.push(i);
    while(!Q.empty())
    {
        i = Q.front();
        Q.pop();
        cnt++;
        p = G->adjlist[i].firstedge;
        while(p != NULL)
        {
            j = p->adjvex;
            G->adjlist[j].count--;
            if(G->adjlist[j].count == 0)
              Q.push(j);
            p = p->next;
        }
    }
    if(cnt != G->n)
      cout<<"NO"<<endl;
    else
      cout<<"YES"<<endl;
}

int main()
{
    ALGraph G;
    while(CreatALGraph(&G))
       TopSort(&G);
    return 0;
}


 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值