centos 7.4 升级/安装 git 2.9.5

1、安装所需软件包

# yum install curl-devel expat-devel gettext-devel openssl-devel zlib-devel 
# yum install gcc perl-ExtUtils-MakeMaker

2、下载&安装

# cd /usr/src
# wget https://www.kernel.org/pub/software/scm/git/git-2.9.5.tar.gz
# tar xzf git-2.9.5.tar.gz
# cd git-2.9.5
# make prefix=/usr/local/git all
# make prefix=/usr/local/git install
# echo "export PATH=$PATH:/usr/local/git/bin" >> /etc/bashrc
# source /etc/bashrc

3、检查版本

# git --version

4、其他

centos自带Git,7.x版本自带git 1.8.3.1(应该是,也可能不是),安装新版本之前需要使用

yun remove git

卸载(安装后卸载也可以)。

执行make prefix=/usr/local/git all时,可能会报错:make: * [git-credential-store] Error 1,此时可以使用以下命令代替

# ./configure --without-iconv
# make CFLAGS=-liconv prefix=/usr/local/git all
# make CFLAGS=-liconv prefix=/usr/local/git install
©️2020 CSDN 皮肤主题: 猿与汪的秘密 设计师:上身试试 返回首页