HDU4630(杭电2013多校第三场1010)

No Pain No Game

Problem Description
Life is a game,and you lose it,so you suicide.
But you can not kill yourself before you solve this problem:
Given you a sequence of number a1, a2, ..., an.They are also a permutation of 1...n.
You need to answer some queries,each with the following format:
If we chose two number a,b (shouldn't be the same) from interval [l, r],what is the maximum gcd(a, b)? If there's no way to choose two distinct number(l=r) then the answer is zero.
 
Input
First line contains a number T(T <= 5),denote the number of test cases.
Then follow T test cases.
For each test cases,the first line contains a number n(1 <= n <= 50000).
The second line contains n number a1, a2, ..., an.
The third line contains a number Q(1 <= Q <= 50000) denoting the number of queries.
Then Q lines follows,each lines contains two integer l, r(1 <= l <= r <= n),denote a query.

Output
For each test cases,for each query print the answer in one line.

Sample Input
1 10 8 2 4 9 5 7 10 6 1 3 5 2 10 2 4 6 9 1 4 7 10

Sample Output
5 2 2 4 3

Source
2013 Multi-University Training Contest 3

题目给出n个数,每个数的范围是1~n的。

n<=50000;

然后查询m次,m<=50000

每次查询[l,r]区间内,两个数的gcd的最大值.

n个数,如果把n个数的约数全部写出来。查询[l,r]之间的gcd的最大值,就相当于找一个最大的数,使得这个数是[l,r]之间至少两个是的约数。

对于一个数n,在sqrt(n)内可以找出所有约数。

我的做法是对查询进行离线处理。

将每个查询按照 l 从大到小排序。

然后 i 从 n~0 ,表示从后面不断扫这些数。

对于数a[i],找到a[i]的所有约数,对于约数x,在x上一次出现的位置加入值x.

这样的查询的时候,只要差值前 r 个数的最大值就可以了。


#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <iostream>
#include <map>
#include <vector>
#include <queue>
#include <set>
#include <string>
#include <math.h>
using namespace std;

const int MAXN = 50010;
int c[MAXN];
int n;
int lowbit(int x)
{
    return x&(-x);
}
void add(int i,int val)
{
    while(i <= n)
    {
        c[i] = max(c[i],val);
        i += lowbit(i);
    }
}
int Max(int i)
{
    int s = 0;
    while(i > 0)
    {
        s = max(s,c[i]);
        i -= lowbit(i);
    }
    return s;
}

int a[MAXN];
int b[MAXN];
int ans[MAXN];

struct Node
{
    int l,r;
    int index;
}node[MAXN];

bool cmp(Node a,Node b)
{
    return a.l > b.l;
}

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int T;
    int m;
    int l,r;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i = 1;i <= n;i++)
            scanf("%d",&a[i]);
        scanf("%d",&m);
        for(int i = 0;i < m;i++)
        {
            scanf("%d%d",&node[i].l,&node[i].r);
            node[i].index = i;
        }
        sort(node,node+m,cmp);
        int i = n;
        int j = 0;
        memset(b,0,sizeof(a));
        memset(c,0,sizeof(c));
        while(j < m)
        {
            while(i > 0 && i>= node[j].l)
            {
                for(int k =1;k*k <= a[i];k++)
                {
                    if(a[i]%k == 0)
                    {
                        if(b[k]!=0)
                        {
                            add(b[k],k);
                        }

                        b[k] = i;
                        if(k != a[i]/k)
                        {
                            if(b[a[i]/k]!=0)
                            {
                                add(b[a[i]/k],a[i]/k);
                            }

                            b[a[i]/k]=i;
                        }
                    }
                }
                i--;
            }
            while(j < m && node[j].l > i)
            {
                ans[node[j].index]=Max(node[j].r);
                j++;
            }
        }
        for(int i = 0;i < m;i++)
            printf("%d\n",ans[i]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值