PAT 1056. Mice and Rice (25)

7 篇文章 0 订阅

1056. Mice and Rice (25)

时间限制
30 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for NP programmers. Then every NG programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NGwinners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: NP and NG (<= 1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains NP distinct non-negative numbers Wi (i=0,...NP-1) where each Wiis the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,...NP-1 (assume that the programmers are numbered from 0 to NP-1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3
Sample Output:
5 5 5 2 5 5 5 3 1 3 5

提交代码

分析:(标记败者)


1.分成group个组,对于每组的败者,其排名均已确定为group+1,并将其标记;


2.首先检查是否标记,
对于未标记的元素

                  若cnt计到ng个就把计数器清0,并把最大值置为这组的第一个,对应修改下标为第一个。


                  若
cnt未计到ng个,就与当前最大值比较,
                                

                                        若大于,则把刚才以为的最大值对应的那个元素标记,并给出排名,更新最大值和下标。
                                        

                                        若小于,则把当前元素进行标记,给出排名。


感谢和山米兰的博客:  http://blog.csdn.net/eli850934234/article/details/8867131  给我提供思路。


#include<stdio.h>
#include<string.h>  //用memset()函数
const int MAX=1010;
int mouse[MAX],order[MAX],rank[MAX];
bool mark[MAX],flag;  //mark[]=1标记败者;flag=1标记剩最后一组(分情况讨论也可以)
int main()
{	
	int	np,ng,i,max,maxid,cnt;
    //freopen("G:\\in.txt","r",stdin);
	while(scanf("%d%d",&np,&ng)!=EOF){
		for(i=0;i<np;i++)
			scanf("%d",&mouse[i]);
		for(i=0;i<np;i++)
			scanf("%d",&order[i]);
		int group=(np%ng==0)?(np/ng):(np/ng+1);
		flag=1; memset(mark,0,sizeof(mark));memset(rank,-1,sizeof(rank));  //全局变量初始化
		while(flag){  //用一种通法巧妙处理好只剩一组的情况
			if(group==1)  //本轮结束后不再执行while()循环
				flag=0;
			cnt=0;max=-1;maxid=-1;  //cnt统计每ng个初始化一次
			for(i=0;i<np;i++){
				if(mark[order[i]]==0){
					if(cnt==ng){   //首先统计个数,每ng个初始化一次
						max=mouse[order[i]];maxid=order[i];cnt=0;  //cnt清0!!!!!!!
						cnt++;
						continue;
					}
					cnt++;
					if(mouse[order[i]]>max){//把之前认为是最大值的那个进行标记,给出排名并更新最大值和下标
						mark[maxid]=1;
						rank[maxid]=group+1;
						maxid=order[i];
						max=mouse[order[i]];
					}
					else{
						rank[order[i]]=group+1;
						mark[order[i]]=1;
					}
				}
			}
			group=(group%ng==0)?(group/ng):(group/ng+1);
		}
		rank[maxid]=1;
		for(i=0;i<np;i++){
			if(i!=0) printf(" ");
			printf("%d",rank[i]);
		}
		printf("\n");
	}

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值