PAT 1056. Mice and Rice (25)

7 篇文章 0 订阅

1056. Mice and Rice (25)

时间限制
30 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for NP programmers. Then every NG programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NGwinners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: NP and NG (<= 1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains NP distinct non-negative numbers Wi (i=0,...NP-1) where each Wiis the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,...NP-1 (assume that the programmers are numbered from 0 to NP-1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3
Sample Output:
5 5 5 2 5 5 5 3 1 3 5

提交代码

分析:(标记败者)


1.分成group个组,对于每组的败者,其排名均已确定为group+1,并将其标记;


2.首先检查是否标记,
对于未标记的元素

                  若cnt计到ng个就把计数器清0,并把最大值置为这组的第一个,对应修改下标为第一个。


                  若
cnt未计到ng个,就与当前最大值比较,
                                

                                        若大于,则把刚才以为的最大值对应的那个元素标记,并给出排名,更新最大值和下标。
                                        

                                        若小于,则把当前元素进行标记,给出排名。


感谢和山米兰的博客:  http://blog.csdn.net/eli850934234/article/details/8867131  给我提供思路。


#include<stdio.h>
#include<string.h>  //用memset()函数
const int MAX=1010;
int mouse[MAX],order[MAX],rank[MAX];
bool mark[MAX],flag;  //mark[]=1标记败者;flag=1标记剩最后一组(分情况讨论也可以)
int main()
{	
	int	np,ng,i,max,maxid,cnt;
    //freopen("G:\\in.txt","r",stdin);
	while(scanf("%d%d",&np,&ng)!=EOF){
		for(i=0;i<np;i++)
			scanf("%d",&mouse[i]);
		for(i=0;i<np;i++)
			scanf("%d",&order[i]);
		int group=(np%ng==0)?(np/ng):(np/ng+1);
		flag=1; memset(mark,0,sizeof(mark));memset(rank,-1,sizeof(rank));  //全局变量初始化
		while(flag){  //用一种通法巧妙处理好只剩一组的情况
			if(group==1)  //本轮结束后不再执行while()循环
				flag=0;
			cnt=0;max=-1;maxid=-1;  //cnt统计每ng个初始化一次
			for(i=0;i<np;i++){
				if(mark[order[i]]==0){
					if(cnt==ng){   //首先统计个数,每ng个初始化一次
						max=mouse[order[i]];maxid=order[i];cnt=0;  //cnt清0!!!!!!!
						cnt++;
						continue;
					}
					cnt++;
					if(mouse[order[i]]>max){//把之前认为是最大值的那个进行标记,给出排名并更新最大值和下标
						mark[maxid]=1;
						rank[maxid]=group+1;
						maxid=order[i];
						max=mouse[order[i]];
					}
					else{
						rank[order[i]]=group+1;
						mark[order[i]]=1;
					}
				}
			}
			group=(group%ng==0)?(group/ng):(group/ng+1);
		}
		rank[maxid]=1;
		for(i=0;i<np;i++){
			if(i!=0) printf(" ");
			printf("%d",rank[i]);
		}
		printf("\n");
	}

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
### 回答1: `kernel.mice(2)` 翻译成中文的意思是 `核心.多重离散数据插补(2)`,是缺失值插补方法之一,用于处理多重离散数据中的缺失值。它是通过模拟马尔科夫链来生成缺失值的多个可能值,然后通过多个回归模型进行插补。其中的参数 2 表示生成的多个可能值的数量。这个方法通常用于处理分类变量中的缺失值。 ### 回答2: 在Python中,kernel.mice(2) 是一种基于多元插补的方法,用于处理数据中的缺失值。该方法使用鼠标算法(Multiple Imputation by Chained Equations, MICE)来估计缺失值,并生成多个完整的数据集。 具体而言,kernel.mice(2)是通过迭代的方式,将数据集中的缺失值替换为估计值。首先,算法通过观察到的数据计算缺失值的条件分布。然后,它使用这些条件分布来模拟缺失值的多个可能值,以创建多个完整的数据集。随后,对于每个数据集,算法会执行建模和分析,得到对应的估计值。最后,每个数据集的估计值被合并成一个单一的结果。 使用kernel.mice(2)可以更好地处理缺失值,因为它考虑了特征之间的相互依赖关系。当数据集中存在多个缺失值或缺失值的分布有一定复杂性时,该方法可以提供更准确的估计。 总之,kernel.mice(2)是一种用于处理缺失值的方法,它通过多元插补和迭代的方式,生成多个完整的数据集,并利用这些数据集进行估计和分析。 ### 回答3: kernel.mice(2)是Python中一个函数的调用,意思是调用名为"kernel.mice"的函数并传入参数值为2。函数名中的"kernel"可能指的是某个核心功能或者框架,而"mice"可能是函数的具体功能或者用途的名称。传入的参数2可能是函数需要使用的某个变量或者数值。具体的功能和参数的含义需要查看函数的定义或者文档来确定。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值