PAT 1014. Waiting in Line (30)

7 篇文章 0 订阅

1014. Waiting in Line (30)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer[i] will take T[i] minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.

At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output "Sorry" instead.

Sample Input
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output
08:07
08:06
08:10
17:00
Sorry

提交代码


感谢孙佰贵学长的博客提供思路:http://blog.csdn.net/sunbaigui/article/details/8656844

1.只有队头的人离开后,后面的人才有选择的权利,即每次寻找队头离开最早的人。

2.每选一个人,他的离开时间是
该窗口最后一个人的离开时间+当前人的服务时间。

3.进行精确的分类


/*
	1、只有队头的人离开后,后面的人还有选择的权利,即每次寻找队头离开最早的人。
	2、每选择一个人,他的离开时间 是 该窗口最后一个人的离开时间+当前人的服务时间。
	3、进行精确的分类
	4、scanf("%d",&process[i]); 千万别掉了&
	5、外内层循环务必使用不同字母
	6、using namespace std别漏了
*/
#include<stdio.h>
#include<string.h>
#include<queue>
const int MAX=1010,INF=0x7fffffff;
using namespace std;
int process[MAX],leave[MAX],winTime[30];//服务时间,离开时间,每个窗口的当前最后时间
queue <int> Q[30];

int main()
{	
    	//freopen("G:\\in.txt","r",stdin);
	
	int i,j,n,m,k,q;//n窗口数  m每个窗口的人数 k需要服务的总人数 q查询人数
	while(scanf("%d%d%d%d",&n,&m,&k,&q)!=EOF){
		for(i=0;i<k;i++)   //注意逻辑序号与物理序号的转化
			scanf("%d",&process[i]);
		memset(winTime,0,sizeof(winTime));
		for(i=0;i<n*m&&i<k;i++){  //优先考虑窗口没满时的站队情况
			winTime[i%n]=winTime[i%n]+process[i];
			leave[i]=winTime[i%n]; //注意winTime已更新,不能再加process[i]!!!!!!!!!!!!!!
			Q[i%n].push(i);
//			printf("%d\n",Q[i%n].back());
//			printf("--%d--\n",leave[i]);

		}
		if(i<k){  //如果黄线区内不够站队,需要在外面排成一队
			for(;i<k;i++){   //还有k-m*n个人需要处理
				int minTime=INF,id;
				for(j=0;j<n;j++){ //找出一个最先处理完的窗口,外层循环用i,内层循环必须换个字母j
					if(leave[Q[j].front()]<minTime){
						minTime=leave[Q[j].front()];
						id=j;
					}
				}
				Q[id].pop();
				Q[id].push(i);
				winTime[id]=winTime[id]+process[i];
				leave[i]=winTime[id];
			}
		}
		for(i=0;i<q;i++){
			int tmp;
			scanf("%d",&tmp);
			tmp--;  //逻辑位序转化为物理位序
//			printf("--%d--\n",leave[tmp]);
			if(leave[tmp]-process[tmp]<540)
				printf("%02d:%02d\n",leave[tmp]/60+8,leave[tmp]%60);
			else
				printf("Sorry\n");
		}
		
	}
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值