HDU To The Max 二维DP

To The Max

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 16   Accepted Submission(s) : 10
Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
  
  
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
 

Sample Output
  
  
15
 

Source
Greater New York 2001
 

Statistic |  Submit |  Back


刚做完一维的,再看二维的有点抓瞎,虽然一开始想到枚举所有的情况,但是对于矩阵来说,就算是模拟枚举我也没想到什么好办法,而且也没去尝试搜索,因为可能感觉会超时吧。

之后看了别人的题解才明白,解决二维DP的原理就是利用压缩的办法,比如题目样例中的1~~2行,我把这两行的对应的列的数字相加,得到一个新的一行数字,如果我相求前两行的最大子矩阵之和的话,那么我直接按照一维的办法去处理这个由1~~~2行压缩成的新的一行的数字即可,不知道大家有没有明白。因为求最大的子矩阵之和肯定是不能断开的,要连续,那么我把两行的数字压缩之后,求解那个一维的最大连续子序列的最大和,也就相当于求1~~2行最大子矩阵之和。

之后就是枚举了,我们从第一行还是枚举,每一次都枚举到最后一行,保证每次求出的结果都是最大值,直接用一个三目运算符就可以解决,最后把她输出就可以了。



// to the maxx//
//题目链接:http://acm.hdu.edu.cn/webcontest/contest_showproblem.php?pid=1005&ojid=0&cid=4493&hide=0

#include<stdio.h>
#include<string.h>
int num[120][120], temp[200];
int n;
int dp(int *b)
{
	int sum = 0;
	int max = 0;
	int i,j;
	for(i = 0;i < n; i++)
	{
		sum += b[i];
		if(sum < 0)
		{
			sum = 0;
		}
		max = max > sum ? max : sum;
	}
	return max;
}
int main()
{
	int i, j, k;
	int max,sum;
	while(scanf("%d", &n) != EOF)
	{
		for(i = 0; i < n; i++)
			for(j = 0; j < n; j++)
				scanf("%d", &num[i][j]);
		max = 0;
		for(i = 0; i < n; i++)
		{
			memset(temp, 0, sizeof(temp));
			for(j = i; j < n; j++)
			{
				for(k = 0; k < n; k++)
					temp[k] += num[j][k];
				sum = dp(temp);
				max = max > sum ? max : sum;
			}
		}
		printf("%d\n", max);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值