求中序遍历序列的第一个结点值(二叉树)

1.题目:


 Problem Description

设有一棵二叉树,其节点值为字符型并假设各值互不相等,采用二叉链表存储表示。现输入其扩展二叉树的前序遍历序列,要求建立该二叉树,并输出其中序遍历序列的第一个结点值。


 Input

第一行为一个整数n,表示以下有n组数据,每组数据占一行,为扩展二叉树的前序遍历序列。


 Output

输出该二叉树中序遍历序列的第一个结点值,若该点不存在则输出"null"。


 Sample Input

2
AB#D##C##
ABD##E##C#F##


 Sample Output

B
D


2.参考代码:


#include <iostream>
using namespace std;

char ans[111];
int t;
struct BiNode{
	char data;
	BiNode* lchild,* rchild;
};

class BiTree{
private:
	BiNode* root;
	BiNode* Creat();
	void Release(BiNode* root);
public:
	BiTree();
	~BiTree();
	BiNode* GetRoot(){
		return root;
	}
	void InOrder(BiNode* root);
};

BiNode* BiTree::Creat(){
	BiNode* root;
	char ch;
	cin>>ch;
	if(ch=='#')
		root=NULL;
	else{
		root=new BiNode;
		root->data=ch;
		root->lchild=Creat();
		root->rchild=Creat();
	}
	return root;
}

void BiTree::Release(BiNode* root){
	if(root){
		Release(root->lchild);
		Release(root->rchild);
		delete root;
	}
}

BiTree::BiTree(){
	root=Creat();
}

BiTree::~BiTree(){
	Release(root);
}

void BiTree::InOrder(BiNode* root){
	if(root==NULL)
		return ;
	else{
		InOrder(root->lchild);
		ans[t++]=root->data;
		InOrder(root->rchild);
	}
}

int main()
{
	int n;
	cin>>n;
	while(n--)
	{
		BiTree bt;
		BiNode* root=bt.GetRoot();
		if(root==NULL){
			cout<<"null\n";
			continue;
		}
		bt.InOrder(root);
		cout<<ans[0]<<endl;
		t=0; 
	}
	return 0;
}





  • 3
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 3
    评论
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值