二叉树的叶子节点(二叉树)

1.题目:


 Problem Description

给你一串扩展二叉树的前序遍历序列,按输入的先后顺序输出该二叉树的叶子节点。


 Input

输入的第一行有一个整数N,表示接下去有N组测试数据,每组测试数据占一行,每组测试数据为一串扩展二叉树的前序遍历序列,节点数据类型为字符型,其中'#'标识该节点为空。


 Output

输出该二叉树中所有的叶子节点,要求其输出顺序与输入时的相对顺序一致,每个叶子节点占一行,每两组测试数据之间有一个空行。空二叉树不输出任何信息。


 Sample Input

2
124#78####35##6##
ABD#G###CE##F##


 Sample Output

8
5
6

G
E
F


2.参考代码:


#include <iostream>
using namespace std;

struct BiNode{
	char data;
	BiNode* lchild,* rchild;
};

class BiTree{
private:
	BiNode* root;
	BiNode* Creat();
	void Release(BiNode* root);
public:
	BiTree();
	~BiTree();
	BiNode* GetRoot(){
		return root;
	}
	void show(BiNode* root);
};

BiNode* BiTree::Creat(){
	BiNode* root=new BiNode;
	char ch;
	cin>>ch;
	if(ch=='#')
		root=NULL;
	else{
		root->data=ch;
		root->lchild=Creat();
		root->rchild=Creat();
	}
	return root;
}

void BiTree::Release(BiNode* root){
	if(root){
		Release(root->lchild);
		Release(root->rchild);
		delete root;
	}
}

BiTree::BiTree(){
	root=Creat();
}

BiTree::~BiTree(){
	Release(root);
}

void BiTree::show(BiNode* root){
	if(root->lchild==NULL && root->rchild==NULL)
		cout<<root->data<<endl;
	if(root->lchild)
		show(root->lchild);
	if(root->rchild)
		show(root->rchild);
}

int main()
{
	int n;
	cin>>n;
	bool flag=false;
	while(n--)
	{
		if(flag)
			cout<<endl;
		flag=true;
		BiTree bt;
		BiNode* root=bt.GetRoot();
		bt.show(root);
	}
	return 0;
}





  • 2
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值