Lost Cows_poj_2182(线段树).java

Lost Cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8312 Accepted: 5305

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands. 

Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow. 

Given this data, tell FJ the exact ordering of the cows. 

Input

* Line 1: A single integer, N 

* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on. 

Output

* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output

2
4
5
3
1
//也可以不用线段树

import java.util.Scanner;

public class Main {
	static Node[] tree;
	public static void main(String[] args) {
        Scanner input=new Scanner(System.in);
        while(input.hasNext()){
        	int n=input.nextInt();
        	tree=new Node[n*6];
        	Build(1,1,n);
        	int[] a=new int[n+5];
        	double[] result=new double[n+5];
        	a[0]=0;
        	for(int i=1;i<n;i++){
        		a[i]=input.nextInt();
        	}
        	for(int i=n-1;i>=0;i--)
        		result[i]=Query(1,a[i]+1);
        	for(int i=0;i<n;i++)
        		System.out.println(String.format("%.0f", result[i]));  
        }
       
	}

	private static double Query(int p, int k) {
		tree[p].len--;
		if(tree[p].left == tree[p].right)
			return tree[p].left;
		int v=p<<1;
		if(tree[v].len>=k)
			return Query(v,k);
		else
			return Query(v+1,k-tree[v].len);
	}

	private static void Build(int p, int left, int right) {
		tree[p]=new Node();
		tree[p].left=left;
		tree[p].right=right;
		tree[p].len=right-left+1;
		if(left==right)
			return;
		int mid=(left+right)>>1;
        int v=p<<1;
        Build(v,left,mid);
        Build(v+1,mid+1,right);
	}
}
class Node{
	int left;
	int right;
	int len;
	Node(){
		
	}
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值