【POJ】 2182 - Lost Cows 【线段树入门】

题目:

Lost Cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9727 Accepted: 6261

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands. 

Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow. 

Given this data, tell FJ the exact ordering of the cows. 

Input

* Line 1: A single integer, N 

* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on. 

Output

* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output

2
4
5
3
1

题目大意:

n个不同编号(范围1-n)的牛,乱序排成一排,已知每头牛前面有多少头牛编号比它小,求该序列中从前往后每头牛的编号

思路:

从后往前遍历输入的序列,遇到的每个值a表示此牛在剩余牛中排在第a+1个,删除此编号,循环此过程,最终得到的序列即为牛在此队列中的编号序列。借助线段树查找未删除的数中排在第a+1个位置(编号排序位置)的牛的位置(读取顺序)

AC代码:

#include <stdio.h>
int s[100000], ans[100000];
struct seg{
	int l, r;
	int len;
}cow[100000];

void build(int v, int l, int r)
{
	cow[v].l = l;
	cow[v].r = r;
	cow[v].len = r - l + 1;
	if (l == r){
		return;
	}
	int mid = (l + r) / 2;
	build(v * 2, l, mid);
	build(v * 2 + 1, mid + 1, r);
}
int query(int v, int k)
{
	--cow[v].len;//长度减一
	if (cow[v].l == cow[v].r){ //找到叶子节点, 注意此处不可用cow[v].len == 0代替,否则单支情况将直接返回,导致未达到最末端
		return cow[v].r;
	}
	else if (cow[v * 2].len >= k){
		return query(v * 2, k);
	}
	else{
		return query(v * 2 + 1, k - cow[v * 2].len);
	}
}
int main()
{
	int n;
	while (~scanf("%d", &n))
	{
		for (int i = 2; i <= n; ++i)
		{
			scanf("%d", &s[i]);
		}
		s[1] = 0;
		build(1, 1, n);
		//从后往前, 对每个s[i] 的值表示此牛在剩余序列中排在第s[i] + 1
		for (int i = n; i >= 1; --i){
			ans[i] = query(1, s[i] + 1);
		}
		for (int i = 1; i <= n; ++i){
			printf("%d\n", ans[i]);
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值