Eight_pku_1077(广搜).java

17 篇文章 0 订阅
12 篇文章 0 订阅

Eight
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 21718 Accepted: 9611 Special Judge

Description

The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as: 
 1  2  3  4 

 5  6  7  8 

 9 10 11 12 

13 14 15  x 

where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle: 
 1  2  3  4    1  2  3  4    1  2  3  4    1  2  3  4 

 5  6  7  8    5  6  7  8    5  6  7  8    5  6  7  8 

 9  x 10 12    9 10  x 12    9 10 11 12    9 10 11 12 

13 14 11 15   13 14 11 15   13 14  x 15   13 14 15  x 

           r->           d->           r-> 

The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively. 

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and 
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course). 

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three 
arrangement. 

Input

You will receive a description of a configuration of the 8 puzzle. The description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle 
 1  2  3 

 x  4  6 

 7  5  8 

is described by this list: 
 1 2 3 x 4 6 7 5 8 

Output

You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line.

Sample Input

 2  3  4  1  5  x  7  6  8 

Sample Output

ullddrurdllurdruldr

/*
 * 感言:广搜,题不是太标准,搜索方向顺序不同,结果不同,
 * 不过可以AC,但是有可能会超时
 * 
 */
import java.util.ArrayDeque;
import java.util.HashMap;
import java.util.Map;
import java.util.Queue;
import java.util.Scanner;

public class Main{
	static Map<String,Integer> map=new HashMap<String, Integer>();
	static Queue<BFS> q=new ArrayDeque<BFS>();
	static String end="12345678x";
	static char g[]=new char[]{'u','l','d','r'};
	static int d[][]=new int[][]{{-1,0},{0,-1},{1,0},{0,1}};//方向不同结果不同
	public static void main(String[] args) {
		Scanner input=new Scanner(System.in);
		String s[][]=new String[3][3];
		while(input.hasNext()){
			map.clear();
			q.clear();
			BFS text=new BFS();
			for(int i=0;i<3;i++){
				for(int j=0;j<3;j++){
					s[i][j]=input.next();
					if(s[i][j].equals("x")){
						text.setX(i);
						text.setY(j);
					}
				}
			}
			text.setS(s);
			map.put(text.getKey(), 0);
			q.add(text);
			System.out.println(bfs(q));
			
		}
	}
	private static String bfs(Queue<BFS> q2) {
		while(!q2.isEmpty()){
			BFS text=q2.poll();
			if(end.equals(text.getKey())){
				return text.getPath().toString();
			}
			for(int i=0;i<4;i++){
				int x=text.getX()+d[i][0];
				int y=text.getY()+d[i][1];
				if(x<0||x>=3||y<0||y>=3)
					continue;
				String f[][]=text.copys();
				f[text.getX()][text.getY()]=f[x][y];
				f[x][y]="x";
				BFS st=new BFS();
				st.setX(x);
				st.setY(y);
				st.setS(f);
				st.getPath().append(text.getPath()).append(g[i]);
				String key=st.getKey();
				if(!map.containsKey(key)){
					q2.add(st);
					map.put(key, 0);
				}
			}
		}
		return "unsolvable";
	}
}

class BFS{
	private Integer x,y;
	private String s[][];
	private StringBuilder path=new StringBuilder();
	public String[][] copys(){
		String c[][]=new String[3][3];
		for(int i=0;i<3;i++)
			for(int j=0;j<3;j++){
				c[i][j]=s[i][j];
			}
		return c;
	}
	public String getKey(){
		StringBuilder a=new StringBuilder();
		for(int i=0;i<3;i++){
			for(int j=0;j<3;j++){
				a.append(s[i][j]);
			}
		}
		return a.toString();
	}
	public int getX() {
		return x;
	}
	public void setX(int x) {
		this.x = x;
	}
	public int getY() {
		return y;
	}
	public void setY(int y) {
		this.y = y;
	}
	public String[][] getS() {
		return s;
	}
	public void setS(String[][] s) {
		this.s = s;
	}
	public StringBuilder getPath() {
		return path;
	}
	public void setPath(StringBuilder path) {
		this.path = path;
	}
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值