HDU-1043 逆向bfs 打表

Problem Description
The 15-puzzle has been around for over 100 years; even if you don’t know it by that name, you’ve seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let’s call the missing tile ‘x’; the object of the puzzle is to arrange the tiles so that they are ordered as:

1  2  3  4
5  6  7  8
9  10 11 12
13 14 15 x

where the only legal operation is to exchange ‘x’ with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:

1  2  3  4     1  2  3  4     1  2  3  4     1  2  3  4
5  6  7  8     5  6  7  8     5  6  7  8     5  6  7  8
9  x  10 12    9 10  x  12    9 10  11 12    9 10  11 12
13 14 11 15    13 14 11 15    13 14  x 15    13 14 15 x
            r->            d->            r->

The letters in the previous row indicate which neighbor of the ‘x’ tile is swapped with the ‘x’ tile at each step; legal values are ‘r’,‘l’,‘u’ and ‘d’, for right, left, up, and down, respectively.
Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing ‘x’ tile, of course).
In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three
arrangement.
Input
You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus ‘x’. For example, this puzzle
1 2 3
x 4 6
7 5 8
is described by this list:
1 2 3 x 4 6 7 5 8
Output
You will print to standard output either the word ``unsolvable’’, if the puzzle has no solution, or a string consisting entirely of the letters ‘r’, ‘l’, ‘u’ and ‘d’ that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases.
Sample Input
2 3 4 1 5 x 7 6 8
Sample Output
ullddrurdllurdruldr
解题思路:
康托展开记录状态
代码:

#include<bits/stdc++.h>
using namespace std;
inline int read(){
        int x=0,f=0;char ch=getchar();
        while(ch>'9'||ch<'0')f|=ch=='-',ch=getchar();
        while(ch>='0'&&ch<='9')x=(x<<3)+(x<<1)+(ch^48),ch=getchar();
        return f?-x:x;
}
const int FAC[10]={1,1,2,6,24,120,720,5040,40320};
int cantor(int *a,int n){
	int x=0;
	for(int i=0;i<n;++i){
		int smaller=0;
		for(int j=i+1;j<n;++j)if(a[j]<a[i])++smaller;
		x+=FAC[n-i-1]*smaller;
	}
	return x;
}
void decantor(int x,int n,int *ans){
	vector<int> v,a;
	for(int i=1;i<=n;++i)v.push_back(i);
	for(int i=n;i>=1;--i){
		int r=x%FAC[i-1],t=x/FAC[i-1]; x=r;
		sort(v.begin(),v.end());
		a.push_back(v[t]);
		v.erase(v.begin()+t);
	}
	for(int i=0;i<n;++i)ans[i]=a[i];
}
int tp[10]={1,2,3,4,5,6,7,8,0};
bool vis[362880];
char ans[362880][41],c;
struct state{
	int hash,x,y,len;
};
void bfs(){
	queue<state>q;
	memset(vis,0,sizeof(vis));
	int hash=cantor(tp,9);
	vis[hash]=1;
	q.push({hash,2,2,0});
	while(!q.empty()){
		state now=q.front();q.pop();
		decantor(now.hash,9,tp);
		int x=now.x,y=now.y;
		if(x>=1){
			swap(tp[x*3+y],tp[(x-1)*3+y]);
			hash=cantor(tp,9);
			if(!vis[hash]){
				q.push({hash,x-1,y,now.len+1}),vis[hash]=1;
				memcpy(ans[hash],ans[now.hash],sizeof(ans[now.hash]));
				ans[hash][now.len]='d';
			}
			swap(tp[x*3+y],tp[(x-1)*3+y]);
		}if(y>=1){
			swap(tp[x*3+y],tp[x*3+y-1]);
			hash=cantor(tp,9);
			if(!vis[hash]){
				q.push({hash,x,y-1,now.len+1}),vis[hash]=1;
				memcpy(ans[hash],ans[now.hash],sizeof(ans[now.hash]));
				ans[hash][now.len]='r';
			}
			swap(tp[x*3+y],tp[x*3+y-1]);
		}if(x<=1){
			swap(tp[x*3+y],tp[(x+1)*3+y]);
			hash=cantor(tp,9);
			if(!vis[hash]){
				q.push({hash,x+1,y,now.len+1}),vis[hash]=1;
				memcpy(ans[hash],ans[now.hash],sizeof(ans[now.hash]));
				ans[hash][now.len]='u';
			}
			swap(tp[x*3+y],tp[(x+1)*3+y]);
		}if(y<=1){
			swap(tp[x*3+y],tp[x*3+y+1]);
			hash=cantor(tp,9);
			if(!vis[hash]){
				q.push({hash,x,y+1,now.len+1}),vis[hash]=1;
				memcpy(ans[hash],ans[now.hash],sizeof(ans[now.hash]));
				ans[hash][now.len]='l';
			}
			swap(tp[x*3+y],tp[x*3+y+1]);
		}
	}
}
int main(){
	bfs();
	while(cin>>c){
		if(c=='x')tp[0]=0;
		else tp[0]=c-'0';
		for(int i=1;i<9;++i)cin>>c,tp[i]=(c=='x')?0:c-'0';
		int hash=cantor(tp,9);
		if(vis[hash]){
			int len=strlen(ans[hash]);
			for(int i=len-1;i>=0;--i)printf("%c",ans[hash][i]);
			putchar('\n');
		}
		else puts("unsolvable");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值