POJ 1655

                                                                                                                   I - Balancing Act

Crawling in process... Crawling failed                                                Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

                                                                                                                 Submit Status

 

Description

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees.  Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T.
For example, consider the tree:

Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two.

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number.

Input

The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.

Output

For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.

Sample Input

1
7
2 6
1 2
1 4
4 5
3 7
3 1

Sample Output

1 2

 

题意:给你一棵树,去掉一个结点之后,得到的值是分开的所有子树中的个数的最大值,要求去掉哪个结点,值最小

算法:dfs,递归过程中,统计孩子结点所有值的总数,然后n-sum就是另一半的值,这个跟所有孩子结点中的最大值对比,取最大那个,一次dfs就

可以把所有值统计出来了,最后找最小那个就可以了*/

#include<cstdio>

#include<iostream>

#include<cstring>

#include<cmath>

#include<queue>

#include<map>

#include<cctype>

#include<vector>

#include<string>

#include<deque>

#include<stack>

#include<ctime>

#include<cstdlib>

#include<algorithm>

#include<set>



using namespace std;



typedef __int64 LL;

#define MAXN 1000

#define IF 1<<30

#define EPS 1e-10



int n,m;

int Min;

vector<int> vec[20005];

int val[20005];

int dfs(int pre,int u){

     int size = vec[u].size();

     if(pre!=0&&size==1){

         val[u] = n - 1;

         return 1;

     }

     int sum = 1,Max = 0;

     for(int i = 0;i<size;i++){

         int v = vec[u][i];

         if(v!=pre){

              int tmp = dfs(u,v);

              sum+=tmp;

              Max = max(Max,tmp);

         }

     }

     val[u] = max(n - sum,Max);

     return sum;

}

int main(){

     int i,j;

     int t;

     int u,v;

     //freopen("in","r",stdin);

     scanf("%d",&t);

     while(t--){

         scanf("%d",&n);

         for(int i = 0;i<=n;i++) vec[i].clear();

         for(int i = 1;i<n;i++){

              scanf("%d%d",&u,&v);

              vec[u].push_back(v);

              vec[v].push_back(u);

         }

         Min = 1<<30;

         dfs(0,1);

         int u = 0;

         for(int i = 1;i<=n;i++){

              if(val[i]<Min){

                   u = i;

                   Min = val[i];

              }

         }

         printf("%d %d\n",u,Min);

     }

}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值