HDU 1003Max Sum

传送门:Max Sum

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 125409    Accepted Submission(s): 28979


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 

Author
Ignatius.L

解题报告:

如果暴力解,复杂度为O(n^2)那么铁定超时。不难发现此题可以用DP思想。状态转移方程dp[j]=max(dp[i],dp[i-1]+arr[i]).代码如下:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int arr[100005];
int main(){
    int t,n,s;
    int beg,ed,maxn,sum,si;
    s=0;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d",&arr[i]);
        beg=0;ed=0;si=0;maxn=arr[0];sum=arr[0];
        for(int i=1;i<n;i++){
            if(sum+arr[i]<arr[i]){
                sum=arr[i];
                si=i;
            }
            else
                sum+=arr[i];
            if(sum>maxn){
                maxn=sum;
                beg=si;
                ed=i;
            }
        }
        printf("Case %d:\n%d %d %d\n",++s,maxn,beg+1,ed+1);
        if(t)
            printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值