[数论] POJ 3126 Prime Path

传送门:Prime Path

Prime Path
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10897 Accepted: 6199

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. 

Now, the minister of finance, who had been eavesdropping, intervened. 
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

Source


解题报告:

此题题意不难理解,就是求从一个素数A变到另一个素数B的路程长度,要求每个走过的数必须是素数且路程最短。

首先想到的是筛选出10000以内所有的素数,然后搜索。

由于需要最短的路程,所以使用BFS,然后枚举每一个数即可


代码如下:

#include <cstdio>
#include <cstring>
using namespace std;

bool prime[10010];
bool visit[10010];
struct node
{
	int step;
	int prime;
}queue[10000];
int bfs(int a,int b){
	int head=0,tail=0;
	queue[tail].prime=a;
	queue[tail++].step=0;
	visit[a]=true;
	while(head<tail){
		node x=queue[head++];
		if(x.prime==b){
			return x.step;
		}
		for(int i=1;i<=9;i+=2){   //个位
			int y=(x.prime/10)*10+i;
			if(y!=x.prime && !visit[y] && !prime[y]){
				visit[y]=true;
				queue[tail].prime=y;
				queue[tail++].step=x.step+1;
			}
		}

		for(int i=0;i<=9;i++){  //十位
			int y=(x.prime/100)*100+i*10+x.prime%10;
			if(y!=x.prime && !visit[y] && !prime[y]){
				visit[y]=true;
				queue[tail].prime=y;
				queue[tail++].step=x.step+1;
			}
		}

		for(int i=0;i<=9;i++){  //百位
			int y=(x.prime/1000)*1000+i*100+((x.prime/10)%10)*10+x.prime%10;
			if(y!=x.prime && !visit[y] && !prime[y]){
				visit[y]=true;
				queue[tail].prime=y;
				queue[tail++].step=x.step+1;
			}
		}

		for(int i=1;i<=9;i++){  //千位
			int y=x.prime%1000+i*1000;
			if(y!=x.prime && !visit[y] && !prime[y]){
				visit[y]=true;
				queue[tail].prime=y;
				queue[tail++].step=x.step+1;
			}
		}
	}
	return -1;
}
int main(){
	memset(prime,0,sizeof(prime));
	prime[0]=1;prime[1]=1;
	for(int i=2;i*i<=10000;i++)
		if(!prime[i])
			for(int j=i+i;j<=10000;j+=i)
				prime[j]=1;
	int t;
	scanf("%d",&t);
	while(t--){
		memset(visit,false,sizeof(visit));
		int a,b;
		scanf("%d%d",&a,&b);
		int ans = bfs(a,b);
		if(ans==-1)
			printf("Impossible\n");
		else
			printf("%d\n",ans);
	}
}


  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值