POJ3126 Prime Path(BFS+数论)【模板】

Prime Path

HERE

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.
Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don’t know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on… Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

题目大意

给你一个素数,每次只能改变这个数的某一位数字,要求改变后的数字还是素数,问经过多少字改动,能得到目标素数。

思路

读题两小时,做题两小时。先用欧拉筛(应该是)打素数表,然后使用BFS搜索。注意不用变换的情况,话说这个点WA了我一次。BFS中的flag特判可以移到while开始就判断。

代码

#include <iostream>
#include <cstring>
#include <queue>
using namespace std;
bool Is_Prime[10000],vis[10000];
int prime[10000];
//欧氏筛打素数表 
void Make_Prime(int n)
{
	memset(Is_Prime,true,sizeof(Is_Prime));
	memset(prime,0,sizeof(prime));
	Is_Prime[0]=Is_Prime[1]=false;
	int top=0;
	for (int i=2; i<=n; i++)
	{
		if (Is_Prime[i])
		{
			prime[top++]=i;
		}
		for (int j=0; j<top; j++)
		{
			if (prime[j]*i>n) break;
			Is_Prime[prime[j]*i]=false;
			if (i%prime[j]==0) break;
		}
	}
}
//记录每个数的每一位 
struct node
{
	int t[4];
	int step;
	node() {};
	node(int num,int n)
	{
		t[0]=num/1000;
		num%=1000;
		t[1]=num/100;
		num%=100;
		t[2]=num/10;
		num%=10;
		t[3]=num;
		step=n;
	}
};
int main()
{
	Make_Prime(10000);
	int t;
	cin>>t;
	while (t--)
	{
		int ans=-1,begin=0,end=0;
		cin>>begin>>end;
		//特判不用变换 
		if (begin==end)
		{
			cout<<0<<endl;
			continue;
		} 
		bool flag=false;//判断是否找到 
		queue<node> Q;
		Q.push(node(begin,0));
		memset(vis,true,sizeof(vis));
		vis[begin]=false;
		while (!Q.empty())
		{
			node now=Q.front();
			Q.pop();
			for (int i=0; i<4; i++)
			{
				int temp[4];
				memcpy(temp,now.t,sizeof(temp));
				for (int j=0; j<=9; j++)
				{
					temp[i]=j;
					if (temp[0]*1000+temp[1]*100+temp[2]*10+temp[3]==end)
					{
						ans=now.step+1;
						flag=true;
						break;
					}
					if (
					    temp[0]*1000+temp[1]*100+temp[2]*10+temp[3]>=1000
					    &&temp[0]*1000+temp[1]*100+temp[2]*10+temp[3]<=9999
					    &&vis[temp[0]*1000+temp[1]*100+temp[2]*10+temp[3]]
					    &&Is_Prime[temp[0]*1000+temp[1]*100+temp[2]*10+temp[3]]
					)
					{
						vis[temp[0]*1000+temp[1]*100+temp[2]*10+temp[3]]=false;
						Q.push(node(temp[0]*1000+temp[1]*100+temp[2]*10+temp[3],now.step+1));
					}
				}
				if (flag) break;
			}
			if (flag) break;
		}
		if (ans!=-1)
		{
			cout<<ans<<endl;
		}
		else
		{
			cout<<"Impossible"<<endl;
		}
	}
	return 0;
}

tips:

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值