[第三次训练]Help Johnny

Help Johnny

Description

Poor Johnny is so busy this term. His tutor threw lots of hard problems to him and demanded him to 
accomplish those problems in a month. What a wicked tutor! After cursing his tutor thousands of times, 
Johnny realized that he must start his work immediately.  
The very problem Johnny should solve firstly is about a strange machine called Warmouth. In the Warmouth 
there are many pairs of balls. Each pair consists of a red ball and a blue ball and each ball is assigned a value. 
We can represent a pair in the form of (R, B) in which R is the value of the red ball and B is of the blue one. 
Warmouth has a generator to calculate the match value of two pairs. The match value of (R1, B1) and (R2, 
B2) is R1*B2+R2*B1. Initially, Warmouth is empty. Pairs are sent into Warmouth in order. Once a new pair 
comes, it will be taken into the generator with all the pairs already in Warmouth.  
Johnny’s work is to tell his tutor the sum of all match values given the list of pairs in order. As the best 
friend of Johnny, would you like to help him? 

Input

The first line of the input is T (no more than 10), which stands for the number of lists Johnny received.  
Each list begins with “N“(without quotes). N is the number of pairs of this list and is no more than 100000. 
The next line gives N pairs in chronological order. The 2i-th number is the value of the red ball of the i-th 
pair and the (2i+1)-th number is the value of the blue ball of the i-th pair. The numbers are positive integers 
and smaller than 100000. 

Output

Please output the result in a single line for each list.  

Sample Input

2
3
1 3 2 2 3 1
2
4 5 6 7

Sample Output

26
58

HINT


解题报告

此题题意是计算(R,B)的值,有两种方式。
第一种方式:直接公式计算(a1+a2+……+an)(b1+b2+……+bn)-a1b1-a2b2-……-anbn (a为R,b为B)
第二种方式:是利用另类乘法分配率。
例如 (R,B)如下:
1 1
2 2
3 3
那么先利用交叉相乘第一个(R,B)和第二个(R,B) 1*2+1*2=4,然后在把第一个的(R,B)加到第二个(R,B)上,那么就是
3 3
3 3
然后第二个与第三个交叉相乘,3*3+3*3=18,结果就是把所有算出来的值相加18+4=22,所以22就是答案。

两种方法各有千秋吧,本人使用的是第二种方法,代码如下:
#include<stdio.h>
#include<string.h>
long long m[100010],n[100010];
int main()
{
    int i,a,x;
    long long ans;
    scanf("%d",&a);
    while(a--)
    {
        ans=0;
        memset(m,0,sizeof(m));
        memset(n,0,sizeof(n));
        scanf("%d",&x);
        for(i=0;i<x;i++)
            scanf("%lld%lld",&m[i],&n[i]);
        for(i=0;i<x-1;i++)
        {
            ans+=m[i]*n[i+1]+m[i+1]*n[i];
            m[i+1]=m[i]+m[i+1];
            n[i+1]=n[i]+n[i+1];
        }
        printf("%lld\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值