hdu 4435 charge-station ( 贪心+bfs )

charge-station

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 616    Accepted Submission(s): 309


Problem Description
There are n cities in M^3's empire. M^3 owns a palace and a car and the palace resides in city 1. One day, she wants to travel around all the cities from her palace and finally back to her home. However, her car has limited energy and can only travel by no more than D meters. Before it was run out of energy, it should be charged in some oil station. Under M^3's despotic power, the judge is forced to build several oil stations in some of the cities. The judge must build an oil station in city 1 and building other oil stations is up to his choice as long as M^3 can successfully travel around all the cities.
Building an oil station in city i will cost 2 i-1 MMMB. Please help the judge calculate out the minimum cost to build the oil stations in order to fulfill M^3's will.
 

Input
There are several test cases (no more than 50), each case begin with two integer N, D (the number of cities and the maximum distance the car can run after charged, 0 < N ≤ 128).
Then follows N lines and line i will contain two numbers x, y(0 ≤ x, y ≤ 1000), indicating the coordinate of city i.
The distance between city i and city j will be ceil(sqrt((xi - xj) 2 + (yi - yj) 2)). (ceil means rounding the number up, e.g. ceil(4.1) = 5)
 

Output
For each case, output the minimum cost to build the oil stations in the binary form without leading zeros.
If it's impossible to visit all the cities even after all oil stations are build, output -1 instead.
 

Sample Input
  
  
3 3 0 0 0 3 0 1 3 2 0 0 0 3 0 1 3 1 0 0 0 3 0 1 16 23 30 40 37 52 49 49 52 64 31 62 52 33 42 41 52 41 57 58 62 42 42 57 27 68 43 67 58 48 58 27 37 69
 

Sample Output
  
  
11 111 -1 10111011
Hint
In case 1, the judge should select (0, 0) and (0, 3) as the oil station which result in the visiting route: 1->3->2->3->1. And the cost is 2^(1-1) + 2^(2-1) = 3.
 

Source


题意:
n个城市,一个人想从城市1出发,一次访问n个城市再回到城市1。
他的交通工具车在加过油后只能走d米。
可以在各个城市建造加油站,建造费用cost为2^(i-1)
问能使他访问所有城市且回到1点所需要建造加油站的最小花费,以2进制形式输出。

思路:
建造加油站的费用为2^(i-1),1到i-1城市的都建加油站的花费也比只建第i个城市的加油站花费小。所以想到贪心,尽量使编号大的不建加油站。处理方法为:先将所有的城市都建加油站,然后从大到小一个一个删除。
因为一个点可以走多次,所以每一个建造方案只需要保证加油站都连通,其他点到加油站的距离<d/2就ok了。(想一想,为什么)

代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#define maxn 150
using namespace std;

int n,m,d,ans,flag,xx;
bool oil[maxn],vis[maxn];
int dist[maxn][maxn],mind[maxn];
struct Node
{
    double x,y;
}pp[maxn];
queue<int>q;

double caldist(int k1,int k2)
{
    double x,y;
    x=pp[k1].x-pp[k2].x;
    y=pp[k1].y-pp[k2].y;
    return sqrt(x*x+y*y);
}
void presolve()
{
    int i,j;
    for(i=1;i<=n;i++)
    {
        for(j=i+1;j<=n;j++)
        {
            dist[i][j]=dist[j][i]=ceil(caldist(i,j));
        }
    }
}
bool bfs()
{
    int i,j,nx;
    for(i=1;i<=n;i++)
    {
        mind[i]=1000000000;
    }
    memset(vis,0,sizeof(vis));
    while(!q.empty()) q.pop();
    vis[1]=1;
    q.push(1);
    while(!q.empty())
    {
        nx=q.front();
        q.pop();
        for(i=1;i<=n;i++)
        {
            if(vis[i]) continue ;
            if(oil[i])
            {
                if(dist[nx][i]<=d)
                {
                    vis[i]=1;
                    q.push(i);
                }
            }
            else
            {
                if(mind[i]>dist[i][nx]) mind[i]=dist[i][nx];
            }
        }
    }
    for(i=1;i<=n;i++)
    {
        if(oil[i]&&!vis[i]) return false ;
        if(!oil[i]&&2*mind[i]>d) return false ;
    }
    return true ;
}
bool solve()
{
    int i,j;
    memset(oil,1,sizeof(oil));
    if(!bfs()) return false ;
    for(i=n;i>1;i--)
    {
        oil[i]=0;
        if(!bfs()) oil[i]=1;
    }
    return true ;
}
int main()
{
    int i,j;
    while(~scanf("%d%d",&n,&d))
    {
        for(i=1;i<=n;i++)
        {
            scanf("%lf%lf",&pp[i].x,&pp[i].y);
        }
        presolve();
        if(!solve())
        {
            printf("-1\n");
            continue ;
        }
        i=n;
        while(!oil[i]) i--;
        for(;i>=1;i--)
        {
            printf("%d",oil[i]);
        }
        printf("\n");
    }
    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值