hdu 4611 Balls Rearrangement (找循环节)

Balls Rearrangement

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1700    Accepted Submission(s): 643


Problem Description
  Bob has N balls and A boxes. He numbers the balls from 0 to N-1, and numbers the boxes from 0 to A-1. To find the balls easily, he puts the ball numbered x into the box numbered a if x = a mod A.   Some day Bob buys B new boxes, and he wants to rearrange the balls from the old boxes to the new boxes. The new boxes are numbered from 0 to B-1. After the rearrangement, the ball numbered x should be in the box number b if x = b mod B.
  This work may be very boring, so he wants to know the cost before the rearrangement. If he moves a ball from the old box numbered a to the new box numbered b, the cost he considered would be |a-b|. The total cost is the sum of the cost to move every ball, and it is what Bob is interested in now.
 

Input
  The first line of the input is an integer T, the number of test cases.(0<T<=50)
  Then T test case followed. The only line of each test case are three integers N, A and B.(1<=N<=1000000000, 1<=A,B<=100000).
 

Output
  For each test case, output the total cost.
 

Sample Input
  
  
3 1000000000 1 1 8 2 4 11 5 3
 

Sample Output
  
  
0 8 16
 

Source
 
思路:
将0~N-1分别写成两个矩阵的形式其实就有思路了,每次充满两矩阵中的其中一列,因为初始间隔一定,每走一步或每走多步的相对间隔仍然没变,所以可以一次统计出来(即每次用i+=step代替i++)。这样还有一种情况不能处理,就是两个矩形的宽都很小(即n很大,a、b很小),所以想到找循环节,循环节很容易找即lcm(a,b)。

代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;

typedef long long ll;
ll n,m,a,b,ans,lcm;

ll gcd(ll x,ll y)
{
    ll r=x%y;
    if(r==0) return y;
    return gcd(y,r);
}
void solve()
{
    ll i,j,r,mod,sum,t;
    ll p1,p2,step,mi;
    r=n/lcm;
    mod=n%lcm;
    p1=p2=0;
    sum=t=0;
    for(i=0;i<lcm;i+=step)
    {
        step=min(a-p1,b-p2);      // 充满矩形的一列需要走的步数
        if(i<mod&&i+step+1>=mod)
        {
            t=sum+(mod-i)*fabs(p1*1.0-p2);
        }
        sum+=step*fabs(p1*1.0-p2);
        p1=(p1+step)%a;           // 更新位置指针
        p2=(p2+step)%b;
    }
    ans=r*sum+t;
}
int main()
{
    ll i,j,t,c;
    scanf("%I64d",&t);
    while(t--)
    {
        scanf("%I64d%I64d%I64d",&n,&a,&b);
        c=gcd(a,b);
        lcm=a/c*b;
        solve();
        printf("%I64d\n",ans);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值