poj 3134 Power Calculus (IDA*)

Power Calculus
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 1593 Accepted: 835

Description

Starting with x and repeatedly multiplying by x, we can compute x31 with thirty multiplications:

x2 = x × xx3 = x2 × xx4 = x3 × x, …, x31 = x30 × x.

The operation of squaring can be appreciably shorten the sequence of multiplications. The following is a way to compute x31 with eight multiplications:

x2 = x × xx3 = x2 × xx6 = x3 × x3x7 = x6 × xx14 = x7 × x7x15 = x14 × xx30 = x15 × x15x31 = x30 × x.

This is not the shortest sequence of multiplications to compute x31. There are many ways with only seven multiplications. The following is one of them:

x2 = x × x, x4 = x2 × x2x8 = x4 × x4x8 = x4 × x4x10 = x8 × x2x20 = x10 × x10x30 = x20 × x10x31 = x30 × x.

If division is also available, we can find a even shorter sequence of operations. It is possible to compute x31 with six operations (five multiplications and one division):

x2 = x × xx4 = x2 × x2x8 = x4 × x4x16 = x8 × x8x32 = x16 × x16x31 = x32 ÷ x.

This is one of the most efficient ways to compute x31 if a division is as fast as a multiplication.

Your mission is to write a program to find the least number of operations to compute xn by multiplication and division starting with x for the given positive integer n. Products and quotients appearing in the sequence should be x to a positive integer’s power. In others words, x−3, for example, should never appear.

Input

The input is a sequence of one or more lines each containing a single integer nn is positive and less than or equal to 1000. The end of the input is indicated by a zero.

Output

Your program should print the least total number of multiplications and divisions required to compute xn starting with x for the integer n. The numbers should be written each in a separate line without any superfluous characters such as leading or trailing spaces.

Sample Input

1
31
70
91
473
512
811
953
0

Sample Output

0
6
8
9
11
9
13
12

Source



题意:

通过乘法和除法将 X 变为 X^n ,找出最快需要几步,每一步相乘或相除的数都需要再次之前出现过。


思路:

IDA*,每次限制深度往下搜,A*剪枝为 设当前的数为x^a,那么这个数通过平方迭代增长最大次数都不能达到n的话就剪枝。增长过程为 x^a->x^2a->x^4a->x^8a...


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 2005
#define MAXN 100005
#define mod 1000000007
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

int n,m,ans,k,flag,cnt,deep;
int vis[maxn];

void dfs(int pos)
{
    int i,j,t;
    if(flag||pos>deep||(vis[pos]<<(deep-pos))<n) return ; // 通过自身相乘(即指数相加 最快方式)都不能达到n 剪枝
    if(vis[pos]==n)
    {
        flag=1;
        return ;
    }
    for(i=1;i<=pos;i++)
    {
        if(flag) return ;
        t=vis[pos]+vis[i];
        if(t>0&&t<2000)
        {
            vis[pos+1]=t;
            dfs(pos+1);
        }
        t=vis[pos]-vis[i];
        if(t>0&&t<2000)
        {
            vis[pos+1]=t;
            dfs(pos+1);
        }
    }
}
int main()
{
    int i,j;
    while(scanf("%d",&n),n)
    {
        deep=flag=0;   // deep-多少个数相乘
        vis[1]=1;
        while(!flag)   // 迭代加深
        {
            deep++;
            dfs(1);
        }
        printf("%d\n",deep-1);
    }
    return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值