hdu 2340 Obfuscation

Obfuscation

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 123    Accepted Submission(s): 23


Problem Description
It is a well-known fact that if you mix up the letters of a word, while leaving the first and last letters in their places, words still remain readable. For example, the sentence “tihs snetncee mkaes prfecet sesne”, makes perfect sense to most people.

If you remove all spaces from a sentence, it still remains perfectly readable, see for example: “thissentencemakesperfectsense”, however if you combine these two things, first shuffling, then removing spaces, things get hard. The following sentence is harder to decipher: “tihssnetnceemkaesprfecetsesne”.

You’re given a sentence in the last form, together with a dictionary of valid words and are asked to decipher the text.

 

Input
On the first line one positive number: the number of testcases, at most 100. After that per testcase:

One line with a string s: the sentence to decipher. The sentence consists of lowercase letters and has a length of at least 1 and at most 1 000 characters.

One line with an integer n with 1 ≤ n ≤ 10 000: the number of words in the dictionary.

n lines with one word each. A word consists of lowercase letters and has a length of at least 1 and at most 100 characters. All the words are unique.
 

Output
Per testcase:

One line with the deciphered sentence, if it is possible to uniquely decipher it. Otherwise “impossible” or “ambiguous”, depending on which is the case.
 

Sample Input
  
  
3 tihssnetnceemkaesprfecetsesne 5 makes perfect sense sentence this hitehre 2 there hello hitehre 3 hi there three
 

Sample Output
  
  
this sentence makes perfect sense impossible ambiguous
 

Source
 

题意:
一段文字,将每个单词的首尾字母不变,中间顺序打乱,然后将单词之间的空格去掉,得到一个序列,给出一个这样的序列,给你一个字典,将原文翻译出来。

思路:
从前往后推,记录一个位置是否能到达、到达的总数、到达的一条路径。比较单词能否放入的方法是先比较首尾字母,然后排序后比较中间字符。

代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 1005
#define MAXN 100005
#define mod 1000000000
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

int n,m,ans,cnt,tot,flag;
char s[maxn],res[10005][105];
string S,cur,now;
struct Node
{
    int len,id;
    char endc;
    string s;
} tt;
vector<Node> vn[26];
int vis[1005];

bool isok(int pos,int i)
{
    int j,t=S[pos]-'a',len=vn[t][i].len;
    if(len==-1) return 1;
    if(pos+len+1>=tot) return 0;
    if(vn[t][i].endc!=S[pos+len+1]) return 0;
    string ss=S.substr(pos+1,len);
    sort(ss.begin(),ss.end());
    if(ss==vn[t][i].s) return 1;
    return 0;
}
void solve()
{
    int i,j,t;
    vector<int>vs[1005];
    memset(vis,0,sizeof(vis));
    vis[0]=1;
    for(i=0; i<tot; i++)
    {
        if(!vis[i]) continue ;   // 不能到i
        t=S[i]-'a';
        for(j=0; j<vn[t].size(); j++) // 由i递推
        {
            if(isok(i,j))
            {
                int next=i+vn[t][j].len+2;
                if(vis[next]==0)
                {
                    if(vis[i]==1)
                    {
                        vis[next]=1;
                        vs[next]=vs[i];
                        vs[next].push_back(vn[t][j].id);
                    }
                    else vis[next]=2;
                }
                else vis[next]=2;
            }
        }
    }
    if(vis[tot]==0) printf("impossible\n");
    else if(vis[tot]==2) printf("ambiguous\n");
    else
    {
        for(i=0; i<vs[tot].size()-1; i++)
        {
            printf("%s ",res[vs[tot][i]]);
        }
        printf("%s\n",res[vs[tot][i]]);
    }
}
int main()
{
    int i,j,t;
    scanf("%d",&t);
    while(t--)
    {
        for(i=0; i<26; i++) vn[i].clear();
        scanf("%s",s);
        S=s;
        tot=S.length();
        scanf("%d",&cnt);
        for(i=1; i<=cnt; i++)
        {
            scanf("%s",res[i]);
            cur=res[i];
            int len=cur.length();
            tt.id=i;
            if(len==1)
            {
                tt.len=-1;
                tt.s="";
                tt.endc=res[i][0];
                vn[res[i][0]-'a'].push_back(tt);
            }
            else
            {
                tt.len=len-2;
                tt.s=cur.substr(1,len-2);
                tt.endc=res[i][len-1];
                sort(tt.s.begin(),tt.s.end());
                vn[res[i][0]-'a'].push_back(tt);
            }
        }
        solve();
    }
    return 0;
}






  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值