zoj 3537 Cake (凸包判定+区间dp)

CakeTime Limit: 1 Second      Memory Limit: 32768 KB You want to hold a party. Here's a polygon-shaped cake on the table. You'd like to cut the cake into several triangle-shaped parts for th
摘要由CSDN通过智能技术生成
Cake

Time Limit: 1 Second      Memory Limit: 32768 KB

You want to hold a party. Here's a polygon-shaped cake on the table. You'd like to cut the cake into several triangle-shaped parts for the invited comers. You have a knife to cut. The trace of each cut is a line segment, whose two endpoints are two vertices of the polygon. Within the polygon, any two cuts ought to be disjoint. Of course, the situation that only the endpoints of two segments intersect is allowed.

The cake's considered as a coordinate system. You have known the coordinates of vexteces. Each cut has a cost related to the coordinate of the vertex, whose formula is costi, j = |xi + xj| * |yi + yj| % p. You want to calculate the minimum cost.

NOTICE: input assures that NO three adjacent vertices on the polygon-shaped cake are in a line. And the cake is not always a convex.

Input

There're multiple cases. There's a blank line between two cases. The first line of each case contains two integers, N and p (3 ≤ N, p ≤ 300), indicating the number of vertices. Each line of the following N lines contains two integers, x and y (-10000 ≤ x, y ≤ 10000), indicating the coordinate of a vertex. You have known that no two vertices are in the same coordinate.

Output

If the cake is not convex polygon-shaped, output "I can't cut.". Otherwise, output the minimum cost.

Sample Input
3 3
0 0
1 1
0 2
Sample Output
0


题意:
给定n个点的坐标,先问这些点是否能组成一个凸包,如果是凸包,问用不相交的线来切这个凸包使得凸包只由三角形组成,根据costi, j = |xi + xj| * |yi + yj| % p算切线的费用,问最少的切割费用。

思路:
先判定凸包,求凸包后看点的个数有没有变化。
然后区间dp,dp[i][j]表示切凸多边形i~j时的最小花费,特殊情况顶点个数为2或者3时不用切了为0.
如图i~j引入两条切线ik和kj将凸多边形分为两个凸多边形和一个三角形。
转移dp[i][j]=min(dp[i][k]+dp[k][j]+cost[i][k]+cost[k][j]);
cost[i][j]为切i、j两点时的花费,当j=i+1时花费为0.(凸多边形为三角形)


代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 105
#define MAXN 100005
#define mod 1000000000
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-8
typedef long long ll;
using namespace std;

int cmp(int x)
{
    if(fabs(x)<eps) return 0;
    if(x>0) return 1;
    return -1;
}
int sqr(int x)
{
    return x*x;
}
struct point
{
    int x,y;
    point(){};
    point(int a,int b):x(a),y(b){};
    void input()
    {
        scanf("%d%d",&x,&y);
    }
    friend point operator +(const point &a,const point &b)
    {
        return point(a.x+b.x,a.y+b.y);
    }
    friend point operator -(const point &a,const point &b)
    {
        return point(a.x-b.x,a.y-b.y);
    }
    friend bool operator ==(const point &a,const point &b)
    {
        return cmp(a.x-b.x)==0&&cmp(a.y-b.y)==0;
    }
    friend point operator *(const point &a,const int &b)
    {
        return point(a.x*b,a.y*b);
    }
    friend point operator *(const int &a,const point &b)
    {
        return point(a*b.x,a*b.y);
    }
    friend point operator /(const point &a,const int &b)
    {
        return point(a.x/b,a.y/b);
    }
    int norm()
    {
        return sqrt(sqr(x)+sqr(y));
    }
};
int det(const point &a,const point &b)
{
    return a.x*b.y-a.y*b.x;
}
int dot(const point&a,const point &b)
{
    return a.x*b.x+a.y*b.y;
}
int dist(const point &a,const point &b)
{
    return (a-b).norm();
}

struct polygon_convex
{
    vector<point>p;
    polygon_convex(int Size=0)
    {
        p.resize(Size);
    }
};
bool comp_less(const point &a,const point &b)
{
    return cmp(a.x-b.x)<0||cmp(a.x-b.x)==0&&cmp(a.y-b.y)<0;
}
polygon_convex convex_hull(vector<point> a)
{
    polygon_convex res(2*a.size()+5);
    sort(a.begin(),a.end(),comp_less);
    a.erase(unique(a.begin(),a.end()),a.end());
    int m=0;
    for(int i=0;i<a.size();i++)
    {
        while(m>1&&cmp(det(res.p[m-1]-res.p[m-2],a[i]-res.p[m-2]))<=0) m--;
        res.p[m++]=a[i];
    }
    int k=m;
    for(int i=int(a.size())-2;i>=0;--i)
    {
        while(m>k&&cmp(det(res.p[m-1]-res.p[m-2],a[i]-res.p[m-2]))<=0) m--;
        res.p[m++]=a[i];
    }
    res.p.resize(m);
    if(a.size()>1) res.p.resize(m-1);
    return res;
}

int n,m,ans;
int dp[305][305],cost[305][305];
vector<point> pp;

int main()
{
    int i,j,t;
    while(~scanf("%d%d",&n,&m))
    {
        vector<point> pp;
        point tmp;
        for(i=1;i<=n;i++)
        {
            scanf("%d%d",&tmp.x,&tmp.y);
            pp.push_back(tmp);
        }
        polygon_convex tb=convex_hull(pp);
        if(tb.p.size()!=n) printf("I can't cut.\n");
        else
        {
            if(n==3)
            {
                printf("0\n");
                continue ;
            }
            memset(cost,0,sizeof(cost));
            for(i=0;i<n;i++)
            {
                for(j=i+2;j<n;j++)
                {
                    cost[i][j]=(abs(tb.p[i].x+tb.p[j].x)*abs(tb.p[i].y+tb.p[j].y))%m;
                }
            }
            memset(dp,0x3f,sizeof(dp));
            for(i=0;i<n-2;i++)
            {
                dp[i][i+1]=0;
                dp[i][i+2]=0;
            }
            dp[n-2][n-1]=0;
            for(int len=4;len<=n;len++)
            {
                for(i=0;i<n;i++)
                {
                    j=i+len-1;
                    if(j>=n) break ;
                    for(int k=i+1;k<=j-1;k++)
                    {
                        dp[i][j]=min(dp[i][j],dp[i][k]+dp[k][j]+cost[i][k]+cost[k][j]);
                    }
                }
            }
            printf("%d\n",dp[0][n-1]);
        }
    }
    return 0;
}
/*
3 3
0 0
1 1
0 2

4 10
0 0
2 0
0 2
2 2

5 11
1 1
1 3
3 1
4 2
3 4
*/





  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值