hdu 4249 A Famous Equation (dp 细节)

A Famous Equation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 514    Accepted Submission(s): 153


Problem Description
Mr. B writes an addition equation such as 123+321=444 on the blackboard after class. Mr. G removes some of the digits and makes it look like “1?3+??1=44?”. Here “?” denotes removed digits. After Mr. B realizes some digits are missing, he wants to recover them. Unfortunately, there may be more than one way to complete the equation. For example “1?3+??1=44?” can be completed to “123+321=444” , “143+301=444” and many other possible solutions. Your job is to determine the number of different possible solutions.
 

Input
Each test case describes a single line with an equation like a+b=c which contains exactly one plus sign “+” and one equal sign “=” with some question mark “?” represent missing digits. You may assume a, b and c are non-negative integers, and the length of each number is no more than 9. In the other words, the equation will contain three integers less than 1,000,000,000.
 

Output
For each test case, display a single line with its case number and the number of possible solutions to recover the equation.
 

Sample Input
  
  
7+1?=1? ?1+?1=22
 

Sample Output
  
  
Case 1: 3 Case 2: 1
Hint
There are three solutions for the first case: 7+10=17, 7+11=18, 7+12=19 There is only one solution for the second case: 11+11=22 Note that 01+21=22 is not a valid solution because extra leading zeros are not allowed.
 

Source
 

题意:
给你一个式子a+b=c,有些位变为不确定?,问你有多少种可能使等式成立。
注意不能有前导0,0不算。

思路:
先把a、b都添0位数和c补齐,dp[i][j][k][2]表示到第i位时,a那位数字为j,b那位数字为k,第i位是否有进位的种数。逐位递推,枚举每一位可能的情况,注意前导0的时不要转移。

代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <queue>
#include <string>
#define mod 1000000007
typedef long long ll;
using namespace std;

int n,lena,lenb,lenc;
char s[105];
string a,b,c,aa,bb;
ll ans,dp[15][15][15][2];

void solve()
{
    int i,j,k,jj,kk;
    memset(dp,0,sizeof(dp));
    dp[lenc][0][0][0]=1;
    for(i=lenc; i>0; i--)
    {
        for(j=0; j<=9; j++)
        {
            if(lenc-i==lena&&lena>1&&j==0) continue ;  // 前导0 不要转移
            for(k=0; k<=9; k++)
            {
                if(lenc-i==lenb&&lenb>1&&k==0) continue ; // 前导0 不要转移
                if(dp[i][j][k][0]==0&&dp[i][j][k][1]==0) continue ;
                for(jj=0; jj<=9; jj++)
                {
                    if(!(a[i-1]=='?'||a[i-1]==jj+'0')) continue ;
                    for(kk=0; kk<=9; kk++)
                    {
                        if(!(b[i-1]=='?'||b[i-1]==kk+'0')) continue ;
                        if(c[i-1]=='?'||(jj+kk)%10==c[i-1]-'0')
                        {
                            if(lenc>1&&i-1==0&&jj+kk==0) ;
                            else dp[i-1][jj][kk][(jj+kk>=10)?1:0]+=dp[i][j][k][0];
                        }
                        if(c[i-1]=='?'||(jj+kk+1)%10==c[i-1]-'0')
                        {
                            dp[i-1][jj][kk][(jj+kk+1>=10)?1:0]+=dp[i][j][k][1];
                        }
                    }
                }
            }
        }
    }
    ans=0;
    for(j=0;j<=9;j++)
    {
        if(lena==lenc&&j==0&&lena>1) continue ;
        for(k=0;k<=9;k++)
        {
            if(lenb==lenc&&k==0&&lenb>1) continue ;
            ans+=dp[0][j][k][0];
        }
    }
}
int main()
{
    int i,j,ca=0;
    while(~scanf("%s",s))
    {
        a="";
        lena=lenb=lenc=0;
        for(i=0; s[i]!='+'; i++) lena++,a+=s[i];
        b="";
        for(i++; s[i]!='='; i++) lenb++,b+=s[i];
        c="";
        for(i++; s[i]!='\0'; i++) lenc++,c+=s[i];
        aa=a; bb=b;
        for(i=1; i<=lenc-lena; i++) a="0"+a;
        for(i=1; i<=lenc-lenb; i++) b="0"+b;
        solve();
        printf("Case %d: %I64d\n",++ca,ans);
    }
    return 0;
}
/*
?+0=?
0+?=?
?+?1=??
1?+?=?1
?+??=???
?+??=10?
?+?=?
?+?=??
?????????+?????????=?????????
*/

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值