hdu 3466 Proud Merchants (01背包变形)

Proud Merchants

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 1672    Accepted Submission(s): 671


Problem Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?

 

Input
There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

 

Output
For each test case, output one integer, indicating maximum value iSea could get.

 

Sample Input
  
  
2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
 

Sample Output
  
  
5 11
// 01 背包的变形 变的有点经典
/*
这题因为涉及到q,所以不能直接就01背包了。
因为如果一个物品是5 9,一个物品是5 6,
对第一个进行背包的时候只有dp[9],dp[10],…,dp[m],
再对第二个进行背包的时候,如果是普通的,
应该会借用前面的dp[8],dp[7]之类的,
但是现在这些值都是0,所以会导致结果出错。
于是要想到只有后面要用的值前面都可以得到,那么才不会出错。
设A:p1,q1 B:p2,q2,
如果先A后B,则需满足 Vj-p2>=q1 (1) 才能使背包B时不受A的影响
因为要比较dp[j]与dp[j-p2] 如果dp[j-p2]未更新的话 就会得出错误的结论了
同时也有 Vj-p1>=q2 不成立即 Vj-p1<=q2 (2) (因为B不在A前面)  ps:等于是不管谁在前都不会受影响
由(1)、(2)得 q1-p1<=q2-p2 时 A在B前面 背包B时不会受前面A的影响
ps:自己可以分别用不同的顺序手动模拟一下背包的过程 看哪些受影响 哪些不受
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int n,m;
int f[5005];
struct Tnode
{
    int p,q,v;
}node[505];

bool cmp(const Tnode &x1,const Tnode &x2)
{
    return x1.q-x1.p<x2.q-x2.p;
}
void solve()
{
    int i,j;
    memset(f,0,sizeof(f));
    for(i=1;i<=n;i++)
    {
        for(j=m;j>=node[i].p;j--)
        {
            if(j>=node[i].q)
                f[j]=f[j]>(f[j-node[i].p]+node[i].v)?f[j]:(f[j-node[i].p]+node[i].v);
            else break;
        }
    }
}
int main()
{
    int i,j;
    while(~scanf("%d%d",&n,&m))
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d%d%d",&node[i].p,&node[i].q,&node[i].v);
        }
        sort(node+1,node+n+1,cmp);
        solve();
        printf("%d\n",f[m]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值